Forum: Ruby Rubyzip problem on Vista?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8812d2385b477f8fbbe37f22c40b18c5?d=identicon&s=25 unknown (Guest)
on 2009-04-21 20:01
(Received via mailing list)
Hello,

I bundle my Ruby application in a zip file that I created using
Rubyzip (0.9.1, installed with Windows Installer 1.8.6-26) that fails
to cleanly unzip on Vista. Vista complains with error code 0x80004005
("unspecified error") from its own Extract All command whenever it
tries to unzip a subdirectory in the zip file. You can retry, skip, or
cancel. Retrying causes the same error. Skipping gets past the problem
and the subdirectory and its contents are unzipped correctly. But my
users don't understand what the issue is and they don't always get the
steps right. Does anyone know if there is a bug with Rubyzip on Vista?
8812d2385b477f8fbbe37f22c40b18c5?d=identicon&s=25 unknown (Guest)
on 2009-04-21 20:15
(Received via mailing list)
I went to Rubyzip's sourceforge page and found a good number of open
bugs including one issue with Windows and directories (though may not
be the same one). This library seems like its not being maintained
anymore. Last bugfix was 2/2007? The Windows bug I mentioned open
since 2006. Looks like I'll have to build my zip using other means.
This topic is locked and can not be replied to.