Forum: Radiant CMS sns install

6f6a2e8b30f7ec96a2e0aaaf922761a9?d=identicon&s=25 Benedikt Eickhoff (bene)
on 2009-04-21 05:38
Hi there -!

following along this routine:

http://github.com/radiant/radiant-sns-extension/tree/master

I get this:

wrong argument type nil (expected Module)
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/base.rb:1130:in
`extend'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/base.rb:1130:in
`initialize_template_class'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/base.rb:522:in
`process_without_filters'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/filters.rb:568:in
`process_without_session_management_support'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/session_management.rb:130:in
`sass_old_process'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/plugins/haml/lib/sass/plugin/rails.rb:19:in
`process'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/base.rb:389:in
`process'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:149:in
`handle_request'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:107:in
`dispatch'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:in
`synchronize'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:in
`dispatch'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:120:in
`dispatch_cgi'
    /usr/local/lib/ruby/gems/1.8/gems/radiant-0.7.1/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:35:in
`dispatch'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:76:in
`process'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:74:in
`synchronize'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:74:in
`process'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:159:in
`process_client'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:158:in
`each'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:158:in
`process_client'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in
`initialize'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in
`new'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in
`initialize'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in
`new'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:282:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:281:in
`each'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:281:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:128:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
    /usr/local/bin/mongrel_rails:19:in `load'
    /usr/local/bin/mongrel_rails:19

Any idea?
294bd7630c18e7fb8f9b420b01e18b77?d=identicon&s=25 David Fossil (davidfossil)
on 2009-05-04 13:14
Did you solve this problem?
The exact same issue is haunting me now =\
This topic is locked and can not be replied to.