Forum: NGINX error 499 nginx + php-fpm

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E40f7fb8900eba3c3a2da70faad085fa?d=identicon&s=25 Deepan Chakravarthy (Guest)
on 2009-04-16 16:24
(Received via mailing list)
Hi,
I was using php fast cgi before. Just installed a fresh machine with the
same config and replaced  php-fastcgi with php-fpm.  Now my access logs
show
return status 499 for 20% of the connections.  The whole thing works
fine
for 5 minutes, then for next one minute it throws 499 status, and then
reverts back to normal status.

I do understand that 499 is generated when client closes the connection
before server responds. However that doesn't seem to be appropriate for
my
situations. Moving back to the old server - makes every thing normal.

Regards
Deepan
2974d09ac2541e892966b762aad84943?d=identicon&s=25 swamp_demon (Guest)
on 2009-06-17 15:31
(Received via mailing list)
I have the same problem

nginx 0.7.60 + php5-fpm (PHP 5.2.8 + PHP-FPM 0.5.10)

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1122,2986#msg-2986
2974d09ac2541e892966b762aad84943?d=identicon&s=25 funkdoobiest (Guest)
on 2009-06-23 16:46
(Received via mailing list)
For me following option helped:

proxy_ignore_client_abort on;

Don't know if this is safe.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1122,3295#msg-3295
A8108a0961c6087c43cda32c8616dcba?d=identicon&s=25 Maxim Dounin (Guest)
on 2009-06-23 17:07
(Received via mailing list)
Hello!

On Tue, Jun 23, 2009 at 10:34:10AM -0400, funkdoobiest wrote:

> For me following option helped:
>
> proxy_ignore_client_abort on;
>
> Don't know if this is safe.

It's not forum but mailing list, so it isn't a good idea to
replicate your message serveral times.

Maxim Dounin
This topic is locked and can not be replied to.