Forum: NGINX stat() failed

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
2974d09ac2541e892966b762aad84943?d=identicon&s=25 mrouleau (Guest)
on 2009-04-16 06:11
(Received via mailing list)

when I flood my server with ApacheBench, with a concurrency of 1000 I
expect most of my queries to be backlogged since I have raised backlog
to 8192 by setting nginx listen backlog to that value and also raising
the relevant Linux kernel parameters to support this limit.

Now the behavior I actually get is that I will get alot of stat() ""
failed (24: ) in my error log, with the "some file" part actually being
a file checked for by a rewrite rule. I get this for pretty much every
file that the rewrite rules check for.

Should I change other parameters? My maximum FD (limits.conf) is raised
to 65536, as well as the kernel parameter fs.file-max.

Is this a bug with nginx?

I'm running nginx 0.7.50 on Ubuntu Hardy LTS with lots of 4GB of RAM and
Quad Core CPU.

Any help appreciacted.

Posted at Nginx Forum:,1107,1107#msg-1107
This topic is locked and can not be replied to.