Forum: Ruby on Rails db:migrate fail's after a single simple scaffold in WindowsXP with sqlite3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1091b853263f0c4030ee9d9400e9da7f?d=identicon&s=25 mgirard1 (Guest)
on 2009-04-13 18:30
(Received via mailing list)
I tried the following in a new directory:

C:\Sources\rails> rails blog
[...]

C:\Sources\rails> cd blog
C:\Sources\rails> ruby script/generate scaffold Post title:string
body:text
C:\Sources\rails> rake db:migrate

The migration successfully created the posts table, but the
db:schema:dump target fails in sqlite3_adapter.rb on the "Could not
find table [...]" line.

I did some research and someone suggested to remove the
quote_table_name function call, this fixes that problem for me.

I just though someone else might have the same problem and that this
information might help!

In short remove the line:
        returning structure = @connection.table_info(quote_table_name
(table_name)) do
and replace it by:
        returning structure = @connection.table_info(table_name) do


My environment:

C:\Sources\rails\blog>sqlite3 -version
3.6.12

C:\Sources\rails\blog>ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

C:\Sources\rails\blog>rails -v
Rails 2.3.2
This topic is locked and can not be replied to.