Forum: NGINX nginx 499's returned for apache 200's

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
210828e5a05974e04032816e80f24d99?d=identicon&s=25 P. Tour (phaitour)
on 2009-04-09 21:17
hi all,

i've read through the posts regarding 499s and i know it's meant for
"client closed connections" but it's happening way too often for that to
be the case.  i'm seeing it at a frequency of around 10-15% of all of my
response (rough estimate based on access log).

i have one nginx box with several apache servers behind it.
load on all servers (nginx, apache, db, etc) are all low
no errors on either nginx or apache
the only symptoms i see are the frequent 499s

i'm not too sure what to look at next.  what else can cause a 499?  any
ideas?

thanks!
2974d09ac2541e892966b762aad84943?d=identicon&s=25 funkdoobiest (Guest)
on 2009-06-24 06:59
(Received via mailing list)
I have the same problem.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,940,3288#msg-3288
2974d09ac2541e892966b762aad84943?d=identicon&s=25 funkdoobiest (Guest)
on 2009-06-24 09:48
(Received via mailing list)
For me following option did help:

proxy_ignore_client_abort on;

Don't know if this is safe.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,940,3294#msg-3294
This topic is locked and can not be replied to.