Forum: Ruby on Rails 501 <>: missing or malformed local part

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
6267c43447e17523494c0bddb6e13ab4?d=identicon&s=25 semi (Guest)
on 2009-04-09 18:19
(Received via mailing list)
I get this error when trying to use the actionmailer gem:

Net::SMTPSyntaxError in EmailerController#sendmail

501 <>: missing or malformed local part

Application Trace | Framework Trace | Full Trace

/usr/lib/ruby/1.8/net/smtp.rb:680:in `check_response'
/usr/lib/ruby/1.8/net/smtp.rb:653:in `getok'
/usr/lib/ruby/1.8/net/smtp.rb:635:in `rcptto'
/usr/lib/ruby/1.8/net/smtp.rb:546:in `send0'
/usr/lib/ruby/1.8/net/smtp.rb:545:in `each'
/usr/lib/ruby/1.8/net/smtp.rb:545:in `send0'
/usr/lib/ruby/1.8/net/smtp.rb:472:in `sendmail'
vendor/rails/actionmailer/lib/action_mailer/base.rb:629:in
`perform_delivery_smtp'
/usr/lib/ruby/1.8/net/smtp.rb:379:in `start'
/usr/lib/ruby/1.8/net/smtp.rb:316:in `start'
vendor/rails/actionmailer/lib/action_mailer/base.rb:627:in
`perform_delivery_smtp'
vendor/rails/actionmailer/lib/action_mailer/base.rb:508:in `__send__'
vendor/rails/actionmailer/lib/action_mailer/base.rb:508:in `deliver!'
vendor/rails/actionmailer/lib/action_mailer/base.rb:383:in
`method_missing'
app/controllers/emailer_controller.rb:6:in `sendmail'

What am I doing wrong?
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2009-04-09 23:25
(Received via mailing list)
On Apr 9, 5:17 pm, semi <seminole10...@yahoo.com> wrote:
> I get this error when trying to use the actionmailer gem:
>
> Net::SMTPSyntaxError in EmailerController#sendmail
>
> 501 <>: missing or malformed local part
>

 http://rails.lighthouseapp.com/projects/8994/tickets/1842 ?

Fred
60d38377d023a676fda76f6851585f15?d=identicon&s=25 unknown (Guest)
on 2009-04-10 17:01
(Received via mailing list)
Thanks. My problem was the wrong email format was being entered to the
recipients I was sending to. I think many of these errors are due to
the fact that in the controller they do not get the correct values
from their email form.

On Apr 9, 5:25 pm, Frederick Cheung <frederick.che...@gmail.com>
This topic is locked and can not be replied to.