Forum: RSpec Problems installing the rspec and rspec-rails gems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
89b5f07d70091e70aa40a0d1e3975c1a?d=identicon&s=25 Mike Williams (cmwilliams)
on 2009-04-05 01:08
Hello,

Just purchased my first mac for Ruby on Rails development and I'm in the
process of setting up the environment and installing rspec and
rspec-rails. I'm getting the following error message when trying to
install the gem.

I'm using: sudo gem install rspec

I get:

Successfully installed rspec-1.2.2
1 gem installed
Installing ri documentation for rspec-1.2.2...
Installing RDoc documentation for rspec-1.2.2...
Could not find main page README.rdoc
Could not find main page README.rdoc
Could not find main page README.rdoc
Could not find main page README.rdoc

When I try to run cucumber, it says that rspec and rspec-rails aren't
installed.

What can I do to remedy this?

I'm using Leopard.

Thanks!
39100495c9937c39b2e0c704444e1b4a?d=identicon&s=25 Pat Maddox (Guest)
on 2009-04-05 02:47
(Received via mailing list)
The rspec gem did install successfully, not sure what those doc
warnings are.  Did you install rspec-rails as well?

Pat
89b5f07d70091e70aa40a0d1e3975c1a?d=identicon&s=25 Mike Williams (cmwilliams)
on 2009-04-05 02:52
Pat Maddox wrote:
> The rspec gem did install successfully, not sure what those doc
> warnings are.  Did you install rspec-rails as well?
>
> Pat


I get the same output with rspec-rails when I try to install it.

When I try to run cucumber feature -n I get:

Missing these required gems:
  rpsec  >= 1.2.2
  rpsec-rails  >= 1.2.2

You're running:
  ruby 1.8.6.114 at
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  rubygems 1.3.1 at /Users/mike/.gem/ruby/1.8, /Library/Ruby/Gems/1.8,
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-04-05 05:12
(Received via mailing list)
Hey Mike,

Looks like the problem is installing the rdoc. Try installing with the
--no-rdoc option.

Cheers,
David

Sent from my iPhone
This topic is locked and can not be replied to.