Forum: Ruby Error installing gem "mysql" in Ruby 1.9.1

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0f1f17ba297242e9d3c86d4cc0a6ea85?d=identicon&s=25 Iñaki Baz Castillo (Guest)
on 2009-04-04 14:48
(Received via mailing list)
Hi, trying to install gem "mysql" in Ruby 1.9.1 I get an error:

  error: ‘struct RString’ has no member named ‘ptr’

This is due to RString changes from Ruby 1.8 (now in 1.9.1
RSTRING_PTR(arg)
must be used instead of RSTRING(arg)->ptr).

What can I do to get mysql working in Ruby 1.9.1? where can I get an
updated
MySQL driver?

Thanks a lot.
0f1f17ba297242e9d3c86d4cc0a6ea85?d=identicon&s=25 Iñaki Baz Castillo (Guest)
on 2009-04-04 14:59
(Received via mailing list)
El Sábado 04 Abril 2009, Iñaki Baz Castillo escribió:
> Hi, trying to install gem "mysql" in Ruby 1.9.1 I get an error:
>
>   error: ‘struct RString’ has no member named ‘ptr’
>
> This is due to RString changes from Ruby 1.8 (now in 1.9.1 RSTRING_PTR(arg)
> must be used instead of RSTRING(arg)->ptr).
>
> What can I do to get mysql working in Ruby 1.9.1? where can I get an
> updated MySQL driver?

I've got it from here:
  http://github.com/radar/mysql/tree/master

and also good doc about this issue here:
  http://frozenplague.net/2009/01/ruby-191-rubygems-rails/
This topic is locked and can not be replied to.