Forum: Ruby on Rails Safari 4 invalid auth token

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cacb3e93b8acde0219ad4eb099205a82?d=identicon&s=25 matthooks (Guest)
on 2009-03-31 10:47
(Received via mailing list)
Getting an odd error in Safari 4:

Here's the auth token that's output to my javascript:

4HB8yAW4gU2xEavWOc+kiMoj4XIyCBUK/t704aOQ+co=

Here's what's listed in the parameters:

"authenticity_token"=>"4HB8yAW4gU2xEavWOc kiMoj4XIyCBUK/t704aOQ co="

notice: the +'s are being replaced by spaces.

This a specific safari issue? I haven't even been able to get FF to
give me +'s in my auth token.

~ m
40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (conradwt)
on 2009-03-31 11:00
(Received via mailing list)
On Mon, Mar 30, 2009 at 6:57 PM, matthooks <matthooks@gmail.com> wrote:

>
> notice: the +'s are being replaced by spaces.
>
> This a specific safari issue? I haven't even been able to get FF to
> give me +'s in my auth token.
>
> ~ m
>

Matt, you might want to also log this bug, if you haven't already done
so,
by
clicking the bug button in the upper right of the Safari 4 window.

-Conrad
Cacb3e93b8acde0219ad4eb099205a82?d=identicon&s=25 matthooks (Guest)
on 2009-03-31 21:25
(Received via mailing list)
Yep, I already have. If this is a safari only bug, hopefully we can
get this fixed in the nightly soon...
This topic is locked and can not be replied to.