Forum: Rails-ES Segmentation fault

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Adce10d7f1dbabcdab8f525a59cec32f?d=identicon&s=25 Andrés Gutiérrez (andresgutgon)
on 2009-03-29 20:46
(Received via mailing list)
Hola. Hoy mismo he instalado de nuevo mi Ruby. Ahora tengo esta versión
en:
/opt/ruby/bin/ruby
ruby 1.8.6 (2008-06-20 patchlevel 230) [i686-darwin9.6.0]

Tengo rails 2.3.2 y 2.2.2

Arranco una App que tengo para que tire con rails 2.2.2
RAILS_GEM_VERSION = '2.2.2' unless defined? RAILS_GEM_VERSION

Navego por un par de links bien y de repente se queda la pantalla en
blanco,
miro en el log y veo esto:
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca8c0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10b78d0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca950:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca8c0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10b78d0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca950:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca8c0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10b78d0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca950:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10ca8c0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
ruby(41713,0xa0889720) malloc: *** error for object 0x10b78d0:
Non-aligned
pointer being freed (2)
*** set a breakpoint in malloc_error_break to debug
Segmentation fault
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

He visto en un hilo del blog de rails [1] que hay problemas de seguridad
con
algunas versiones de rails.
[Segmentation fault] Es algo que se repite a lo largo de los comentarios
de
este post [1].

LO QUE YO QUIERO:
Llevo un fin de semana de mierda. He borrado y he vuelto a instalar ruby
y
readline unas cuantas veces por este problema [2]. Pero no me termina de
ir
bien.
La idea que llevo es aprender con la versión más nueva y estable de rail
(ahora 2.3.2)
MI PREGUNTA:
Si yo quiero funcionar con Rails 2.3.2 ¿Con que versión de ruby se lleva
bien rails 2.3.2?

¿Cual usáis?

Estoy en Mac OS X 10.5 Leopard Darwin 9.6

Un saludo

[1]
http://weblog.rubyonrails.org/2008/6/21/multiple-r...
[2]
http://lists.simplelogica.net/pipermail/hacking-es...
9f13f0ff5f5f41f5598ad755f192ca3a?d=identicon&s=25 Luis felipe Hurtado campuzano (luisfelipehurtado)
on 2009-03-29 21:53
(Received via mailing list)
Yo hace poco tuvo algunos problemas con una aplicación que generaba
errores
"segmentation fault", no son exactamente estos mismo errores, pero si
parecidos... al final el problema no tenía nada que ver con Ruby o con
Rails
sino que (sin previo aviso) le habían cambiado la IP a la máquina que
tenía
el motor de base de datos (SQLServer); así que la aplicación no
encontraba
la base de datos. Así, que si no lo has hecho, verifica por un medio
diferente a la aplicación misma, si puedes abrirte una conexión a la
base de
datos.


2009/3/29 Andrés gutiérrez <andresgutgon@gmail.com>
Adce10d7f1dbabcdab8f525a59cec32f?d=identicon&s=25 Andrés Gutiérrez (andresgutgon)
on 2009-03-29 22:06
(Received via mailing list)
No te digo que no haya algo por ahi que tenga que ver con MySQL...pero:
1-Puedo entrar en la App y navegar un poco. Con lo que algunas Querys
tira
antes de fallar
2- Estoy en development. Mi BBDD esta en localhost
3-Accedo a la BBDD por terminal sin problema. y tambien por
script/console
>> @Project1 = Project.find(1)
>> @Project1.name
=> "Mi mini proyecto1"

¿Qué hago?
Me instalo otra versión de Ruby. Cuento un poco como lo veo:
Tenía hace un mes 1.8.7 pero me dio problemas con textmate a la hora de
ejecutar el comando TODO. De ahí que me decidiera a instalar la
1.8.6-p111.

He leido aqui [1] que hay muchas versiones de ruby que tienen
vulneravilidades. Tambien la que muestras en tu blog.

Ahora mi duda es:
¿Qué hago?
Si elijo la 1.8.7 me da problemas con TextMate (demostrado). Soportable
pero
incomodo

1.8.6-p230 la que tengo ahora me suelta el error del ultimo mensaje.

1.8.6-p111 parece que dicen que es más estable
1.8.6-p114 es la que viene con Leopard
1.91. ¿será compatible con los plugins más comunes
(Rest_Ful,will_paginate,...)
Creo que he leido que rails 2.3.2 se lleva bien con ruby 1.9.1. Pero lo
de
que me encuentre con un monton de gemas/plugins incompatibles me hecha
para
atras.

[1] http://weblog.rubyonrails.org/2008/6/21/multiple-rub
y-security-vulnerabilities

2009/3/29 Luis Felipe Hurtado Campuzano <luisfelipehurtado@gmail.com>
9f13f0ff5f5f41f5598ad755f192ca3a?d=identicon&s=25 Luis felipe Hurtado campuzano (luisfelipehurtado)
on 2009-03-29 22:29
(Received via mailing list)
Yo creo que si con 1.8.7 la aplicación está funcionando, deberías
trabajar
con esa version. La cuestión del comando TODO con Textmate, como dices,
es
mas soportable.


2009/3/29 Andrés gutiérrez <andresgutgon@gmail.com>
Adce10d7f1dbabcdab8f525a59cec32f?d=identicon&s=25 Andrés Gutiérrez (andresgutgon)
on 2009-03-30 09:38
(Received via mailing list)
Justo lo que acabas de comentar me he dado cuenta que la misma gente de
rails la recomiendan [1]

Gracias. Instalare esta y a correr

[1] http://rubyonrails.org/download

2009/3/29 Luis Felipe Hurtado Campuzano <luisfelipehurtado@gmail.com>
This topic is locked and can not be replied to.