Forum: Ruby on Rails From Rails 1.2.6 to 2.3.2

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Fc6f5b908cfa12868292f985e0de2788?d=identicon&s=25 elle (Guest)
on 2009-03-24 00:04
(Received via mailing list)
Hello,

I have an application I did in 2007 in Rails 1.2.6. It was my first
one -- so I am sure the code could be improved and better refractored.
If I wanted to upgrade the application to 2.3.2 and hopefully improve
it -- how would you suggest I tackle this? Any advice would be great.

Elle
B14575f0ca69f10938fdd67e7156e0e1?d=identicon&s=25 Craig Demyanovich (Guest)
on 2009-03-24 02:02
(Received via mailing list)
1. Upgrade to latest 2.0.x release, run all of your tests, fix any
failures,
address any deprecations.
2. Upgrade to latest 2.1.x release, run all of your tests, fix any
failures,
address any deprecations.
3. Upgrade to latest 2.2.x release, run all of your tests, fix any
failures,
address any deprecations.
4. Upgrade to latest 2.3.x release, run all of your tests, fix any
failures,
address any deprecations.

You may need to upgrade plugins and/or other tools at one or more steps,
too. I know it seems like a long recipe, but it should keep the problems
to
a minimum along the way.

Regards,
Craig

On Mon, Mar 23, 2009 at 7:03 PM, elle <waznelle@gmail.com> wrote:

>
--
Craig Demyanovich
Mutually Human Software
http://mutuallyhuman.com
Fc6f5b908cfa12868292f985e0de2788?d=identicon&s=25 elle (Guest)
on 2009-03-24 23:23
(Received via mailing list)
So, I've got one more question: how do you upgrade to certain version?

Thanks,
Elle
Aad37b5f7116c8d1f547d23b37566032?d=identicon&s=25 Greg Donald (destiney)
on 2009-03-25 00:34
(Received via mailing list)
On Tue, Mar 24, 2009 at 5:22 PM, elle <waznelle@gmail.com> wrote:
>
> So, I've got one more question: how do you upgrade to certain version?

Change the RAILS_GEM_VERSION in your environment.rb and run `rake
rails:update`.


--
Greg Donald
http://destiney.com/
This topic is locked and can not be replied to.