Forum: RSpec Problem running autotest in rails 2.3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
584a6682a2defd3bc5f7dc85fd6e263d?d=identicon&s=25 Bjorn Boulder (bornboulder)
on 2009-03-22 16:12
(Received via mailing list)
People,

I'm trying to run autotest on rails 2.3

I get a NoMethodError.

Here is what I see:

Sat Mar 21 20:47 /b/tmp/myfc23 maco$
Sat Mar 21 20:47 /b/tmp/myfc23 maco$ autotest
loading autotest/rails_rspec
./vendor/plugins/rspec/lib/autotest/rspec.rb:24:in `initialize':
undefined
method `failed_results_re=' for #<Autotest::RailsRspec:0x1205b88>
(NoMethodError)
        from
/pt/r1/lib/ruby/gems/1.8/gems/ZenTest-3.8.0/lib/autotest.rb:126:in `new'
        from
/pt/r1/lib/ruby/gems/1.8/gems/ZenTest-3.8.0/lib/autotest.rb:126:in `run'
        from /pt/r1/lib/ruby/gems/1.8/gems/ZenTest-3.8.0/bin/autotest:48
        from /pt/r1/bin/autotest:19:in `load'
        from /pt/r1/bin/autotest:19
Sat Mar 21 20:47 /b/tmp/myfc23 maco$
Sat Mar 21 20:47 /b/tmp/myfc23 maco$

Here is info about my rails:


Sat Mar 21 20:47 /b/tmp/myfc23 maco$
Sat Mar 21 20:47 /b/tmp/myfc23 maco$
Sat Mar 21 20:47 /b/tmp/myfc23 maco$ script/about
About your application's environment
Ruby version              1.8.7 (i686-darwin9.6.2)
RubyGems version          1.3.1
Rack version              1.0 bundled
Rails version             2.3.2
Active Record version     2.3.2
Action Pack version       2.3.2
Active Resource version   2.3.2
Action Mailer version     2.3.2
Active Support version    2.3.2
Application root          /b/tmp/myfc23
Environment               development
Database adapter          sqlite3
Database schema version   2
Sat Mar 21 20:51 /b/tmp/myfc23 maco$

Here is a list of my gems:

*** LOCAL GEMS ***

actionmailer (2.3.2, 2.2.2)
actionpack (2.3.2, 2.2.2)
activerecord (2.3.2, 2.2.2)
activeresource (2.3.2, 2.2.2)
activesupport (2.3.2, 2.2.2)
cgi_multipart_eof_fix (2.5.0)
chronic (0.2.3)
columnize (0.3.0)
daemons (1.0.10)
darkfish-rdoc (1.1.5)
diff-lcs (1.1.2)
extlib (0.9.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
highline (1.5.0)
hoe (1.9.0)
hpricot (0.6.164)
libxml-ruby (0.9.8)
linecache (0.43)
mongrel (1.1.5)
mysql (2.7)
newgem (1.2.3)
rack (0.9.1)
rails (2.3.2, 2.2.2)
rake (0.8.4, 0.8.3)
rcov (0.8.1.2.0)
rdoc (2.4.1)
RedCloth (4.1.9)
rhodes (0.3.0)
rspec (1.2.0, 1.1.12)
rspec-rails (1.2.0, 1.1.12)
rubigen (1.5.2)
ruby-debug (0.10.3)
ruby-debug-base (0.10.3)
rubyforge (1.0.3)
sqlite3-ruby (1.2.4, 1.2.3)
syntax (1.0.0)
templater (0.5.0)
ZenTest (3.8.0)

Any tips on debugging this?

-b
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-03-22 16:32
(Received via mailing list)
2009/3/22 Bjorn Boulder <bornboulder77@gmail.com>:
>         from
> Sat Mar 21 20:47 /b/tmp/myfc23 maco$
> Action Mailer version     2.3.2
> activerecord (2.3.2, 2.2.2)
> gem_plugin (0.2.3)
> rake (0.8.4, 0.8.3)
> sqlite3-ruby (1.2.4, 1.2.3)
> syntax (1.0.0)
> templater (0.5.0)
> ZenTest (3.8.0)

I think updating ZenTest will resolve this for you. ZenTest is up to 4.0
now.
This topic is locked and can not be replied to.