Forum: NGINX dynamic png not working

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8072fdc83f765ae5075f252cb4d4d111?d=identicon&s=25 Chris Cortese (Guest)
on 2009-03-15 16:44
(Received via mailing list)
I just noticed on one of my sites that my php script that calls
header("Content-type: image/png") and imagepng(), etc., is not creating
a png image.  This was working before but I've not only switched to
nginx from Apache, I've also switched to a new server, new build of PHP,
etc...

Do I need to do something special with the nginx config to make this
happen?
2e321cc0efe9422d37165e922298494e?d=identicon&s=25 Cliff Wells (Guest)
on 2009-03-15 16:54
(Received via mailing list)
On Sun, 2009-03-15 at 08:33 -0700, Chris Cortese wrote:
> I just noticed on one of my sites that my php script that calls
> header("Content-type: image/png") and imagepng(), etc., is not creating
> a png image.  This was working before but I've not only switched to
> nginx from Apache, I've also switched to a new server, new build of PHP,
> etc...
>
> Do I need to do something special with the nginx config to make this happen?


Your problem is almost certainly related to directory permissions or a
missing PHP library.

Cliff
F5a6ed477b109fe6acc11a5a8f87e7e8?d=identicon&s=25 mike (Guest)
on 2009-03-15 16:55
(Received via mailing list)
no, that'd be a php thing most likely.

try firefox it's a bit more forgiving with incorrect headers. it could
be the build of php doesn't support it, or you have extra characters
in the file being outputted before the png data, so the browser is
getting trash... that's usually the case i see.


On Sun, Mar 15, 2009 at 8:33 AM, Chris Cortese
8072fdc83f765ae5075f252cb4d4d111?d=identicon&s=25 Chris Cortese (Guest)
on 2009-03-16 11:01
(Received via mailing list)
thx for the ideas and you're right, not an nginx issue.  Not sure what
was exactly the final step but I did need to clean up some of php's
config options.
F5a6ed477b109fe6acc11a5a8f87e7e8?d=identicon&s=25 mike (Guest)
on 2009-03-16 13:10
(Received via mailing list)
with php-fpm of course... :)

./configure \
--enable-fastcgi \
--enable-discard-path \
--enable-force-cgi-redirect \
--enable-fpm \
--with-fpm-pid=/var/run/php-fpm.pid \
--with-fpm-log=/var/log/php-fpm.log \
--with-fpm-conf=/etc/php-fpm.conf \
--enable-cli \
--enable-inline-optimization \
--disable-rpath \
--disable-ipv6 \
--enable-mbstring \
--enable-mbregex \
--enable-sqlite-utf8 \
--with-gettext \
--with-mysql \
--with-mysqli=/usr/bin/mysql_config \
--with-curl \
--with-zlib \
--with-gd \
--with-jpeg-dir=/usr \
--with-png-dir=/usr \
--with-freetype-dir \
--enable-gd-native-ttf \
--enable-exif \
--enable-shmop \
--with-xsl=shared \
--with-mssql=shared \
--enable-soap=shared \
--enable-sockets \
--enable-pcntl=shared \
--with-mcrypt \
--with-bz2 \
--with-tidy \
--with-pcre-dir \
--with-openssl \
--with-imap=shared \
--with-imap-ssl \
--with-kerberos \
--with-pear \
--with-gmp


On Sun, Mar 15, 2009 at 9:46 AM, Chris Cortese
This topic is locked and can not be replied to.