Forum: Ruby win32util packages on ruby1.9

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
6087a044557d6b59ab52e7dd20f94da8?d=identicon&s=25 Peña, Botp (Guest)
on 2009-03-14 07:27
(Received via mailing list)
just installed ruby 1.9.1 on windows. and then  installed win32util's
net-ping and popen3.

but when i ran my script i get a popup that it is looking for
msvcrt-ruby18.dll.  Of course, it's not there anymore since ruby 1.9 has
msvcrt-ruby191.dll.  copying the 191.dll to 181.dll result to a  weirder
error...

so my initial question is: does win32util packages support ruby1.9 ?
(this dll thingy is really hell:))
if yes, how do i resolve the error above?

kind regards -botp
666b4e17b4bb0e2d999037a25f65a7cb?d=identicon&s=25 Heesob Park (phasis)
on 2009-03-14 11:55
(Received via mailing list)
Hi,

2009/3/14 Peña, Botp <botp@delmonte-phil.com>:
> just installed ruby 1.9.1 on windows. and then  installed win32util's net-ping and 
popen3.
>
> but when i ran my script i get a popup that it is looking for msvcrt-ruby18.dll.  Of 
course, it's not there anymore since ruby 1.9 has msvcrt-ruby191.dll.  copying the 
191.dll to 181.dll result to a  weirder error...
>
> so my initial question is: does win32util packages support ruby1.9 ?  (this dll thingy 
is really hell:))
> if yes, how do i resolve the error above?
>
Two gems win32-open3 and win32-api are looking for msvcrt-xxx.dll.
As I know, the other gems are pure ruby.
Currently win32utils binary gems don't support ruby1.9 officially. For
the moment, unofficial binary gems are available at
http://121.78.227.9/ruby-1.9.1p0-win32utils-gem/

Regards,

Park Heesob
797ef431a5e1295b56c08e1db4c8d2df?d=identicon&s=25 botp (Guest)
on 2009-03-16 05:08
(Received via mailing list)
From: Heesob Park [mailto:phasis@gmail.com]
# Two gems win32-open3 and win32-api are looking for
# msvcrt-xxx.dll. As I know, the other gems are pure ruby.

not bad

# Currently win32utils binary gems don't support
# ruby1.9 officially. For the moment, unofficial binary
# gems are available at
# http://121.78.227.9/ruby-1.9.1p0-win32utils-gem/

works like a charm.
thank you, park.

(apologies if this gets duplicated. client mail problem here)

kind regards -botp
This topic is locked and can not be replied to.