Forum: Ruby on Rails Any good tutorial about upgrade ruby to 1.9.1 and with rails 2.3?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D4534a68fa60c06a3bc8dad302140fbd?d=identicon&s=25 chenillen (Guest)
on 2009-03-08 15:38
(Received via mailing list)
Hi there,

Just want to upgrade to ruby1.9.1, but some important gems such as
mysql, fastthread, mongrel are not compatible with the newest version,
anyone has some good tutorial for recommendation?

Thanks,

chenillen
247cd3d37084a3d6794076207bd9fbd7?d=identicon&s=25 Bob Martens (Guest)
on 2009-03-08 20:05
(Received via mailing list)
Try it out and report back? I haven't made the jump yet, but I'm sure
someone will pipe up with recommendations at some point.
1732604c725e2ddd83c3ea85d9deb2a6?d=identicon&s=25 Niels Ganser (Guest)
on 2009-03-08 20:21
(Received via mailing list)
A Ruby 1.9 compatible version of mysql-ruby is available from its
author's website: http://tmtm.org/mysql/ruby/.

Fastthread isn't needed to run mongrel under Ruby 1.9, the mongrel gem
still seems to require it though. Tell rubygems to ignore its
dependencies like so: gem install mongrel --ignore-dependencies.

If rubygems fails to build native extensions for mongrel try changing
all occurences of RSTRING("FOOBAR")->ptr with RSTRING_PTR("FOOBAR") and
similarly RSTRING("FOOBAR")->len with RSTRING_LEN("FOOBAR") in http11.c.
Then try building again like so: ruby extconf.rb. Compile with make and
install with make install. This might have already been fixed upstream
though so try ignoring dependencies during installation first!

Best,
Niels
40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (conradwt)
on 2009-03-09 15:39
(Received via mailing list)
On Sat, Mar 7, 2009 at 7:55 PM, chenillen <chenillen@gmail.com> wrote:

>
> Hi there,
>
> Just want to upgrade to ruby1.9.1, but some important gems such as
> mysql, fastthread, mongrel are not compatible with the newest version,
> anyone has some good tutorial for recommendation?
>
> Thanks,
>
> chenillen


Hi, you should be able to find several threads if you search the mailing
list.  I created the following tutorial in regards to using both Ruby
1.9.1
and Rails 2.3.0:

"Using MacPorts To Install Ruby 1.9.1 and Rails 2.3.0 RC1"

Good luck,

-Conrad
This topic is locked and can not be replied to.