Forum: GNU Radio GSL Not Found Error Not Very Helpful

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
79723aa1b24981dcec2dbf7fd59403c1?d=identicon&s=25 Brian Padalino (Guest)
on 2009-03-05 21:36
(Received via mailing list)
I was helping someone on IRC today and it seems the configure script
doesn't explicitly tell which version of GSL is required - but just
says it's not there.

Here is where (I think?) the message originates from:

    http://gnuradio.org/trac/browser/gnuradio/trunk/co...

And their output:

    http://www.pastie.org/408667

They had gsl version 1.9 installed.  Since the check is for 1.10 or
higher, maybe the error message should be more explicit?

Brian
7945befc13c462eb2d6185a129a537ed?d=identicon&s=25 Ben Buley (Guest)
on 2009-03-05 22:16
(Received via mailing list)
I had the same problem when I started building the trunk versions for
the
USRP2 on my Fedora 7 machine.

I'm not sure if there is a more elegant solution, but I only had success
after removing Fedora's GSL package, downloading/building/installing GSL
1.10, and specifying the "PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/"
argument to the configure script.  That was for Fedora 7 (either x86 or
ppc).

I agree though, the error message wasn't clear enough to know if the
anything was found, a version mismatch, or some failed compatibility
test.


- Ben
D0072e69d706bb3ca211d33a1b536e2c?d=identicon&s=25 Johnathan Corgan (Guest)
on 2009-03-08 03:59
(Received via mailing list)
On Thu, Mar 5, 2009 at 12:25 PM, Brian Padalino <bpadalino@gmail.com>
wrote:

> They had gsl version 1.9 installed.  Since the check is for 1.10 or
> higher, maybe the error message should be more explicit?

This is fixed in trunk r10576.

Thanks,

Johnathan
This topic is locked and can not be replied to.