Forum: RSpec RSpec with edge rails (2.3 RC1)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ebc1e0dfecc4345887f07239f102ad3e?d=identicon&s=25 George Anderson (Guest)
on 2009-02-25 20:56
(Received via mailing list)
Hi,

I'm failing miserably to get RSpec running with edge rails (2.3 RC1).
I've tried building/installing the 1.1.99.1 gems from David's git
repos (http://github.com/dchelimsky/rspec-rails and
http://github.com/dchelimsky/rspec), but no luck.

I realize "releases with a 4th partial [are] interim (unofficial)
release[s]" and I should use them at my own risk.  Could someone
kindly provide fairly explicit instructions for getting RSpec running
with 2.3 RC1?  I suspect I'm making things more difficult than they
are.

If needed I can post error messages, but I'm not sure I'm on the right
path to start with, so I don't think that would be helpful.

Thanks,

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george@benevolentcode.com
874be46e8593deadb2cec84b70b26725?d=identicon&s=25 Yi Wen (hayafirst)
on 2009-02-25 21:18
(Received via mailing list)
I have edge rails along with RSpec 1.1.99. works fine. What errors do
you
get?

On Wed, Feb 25, 2009 at 1:24 PM, George Anderson
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-02-25 21:23
(Received via mailing list)
On Wed, Feb 25, 2009 at 1:24 PM, George Anderson
<george@benevolentcode.com> wrote:
> Hi,
>
> I'm failing miserably to get RSpec running with edge rails (2.3 RC1).
> I've tried building/installing the 1.1.99.1 gems from David's git
> repos (http://github.com/dchelimsky/rspec-rails and
> http://github.com/dchelimsky/rspec), but no luck.

We're up to 1.1.99.9 now - have you tried that?
Ebc1e0dfecc4345887f07239f102ad3e?d=identicon&s=25 George Anderson (Guest)
on 2009-02-25 21:57
(Received via mailing list)
>From David: > We're up to 1.1.99.9 now - have you tried that?

Sorry, yes, I meant 1.1.99.1.

~/work/rspec (master) $ gem list rspec

*** LOCAL GEMS ***

rspec (1.1.99.9)
rspec-rails (1.1.99.9)


This is what I did:

cloned: git://github.com/dchelimsky/rspec.git
rake gem
rake install_gem

cloned: git://github.com/dchelimsky/rspec-rails.git
rake gem
rake install_gem

In my project:
script/generate rspec

#      modified:   lib/tasks/rspec.rake
#  modified:   script/autospec
#  modified:   spec/spec_helper.rb


spec spec/models/html_page_spec.rb
/opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
`report_activate_error': RubyGem version error: rspec(1.1.99.9 not =
1.1.11.1) (Gem::LoadError)
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:158:in
`require'
  from ./spec/models/../spec_helper.rb:6
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
   ... 7 levels...
  from
/opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/lib/spec/runner/command_line.rb:9:in
`run'
  from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/bin/spec:4
  from /opt/local/bin/spec:19:in `load'
  from /opt/local/bin/spec:19


spec_helper.rb (line 6)
require 'spec/rails'

$ cat spec_helper.rb
ENV["RAILS_ENV"] = "test"
require File.expand_path(File.dirname(__FILE__) +
"/../config/environment")
require 'spec'
require 'spec/rails'

Spec::Runner.configure do |config|
  config.use_transactional_fixtures = true
  config.use_instantiated_fixtures  = false
  config.fixture_path = RAILS_ROOT + '/spec/fixtures/'
end


So it looks as if I need to update the dependency version for rspec to
be 1.1.99.9, but I'm not sure where I need to do that.

Thanks,

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george@benevolentcode.com
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-02-25 22:38
(Received via mailing list)
On Wed, Feb 25, 2009 at 2:35 PM, George Anderson
<george@benevolentcode.com> wrote:
>
>
> This is what I did:
>
> cloned: git://github.com/dchelimsky/rspec.git
> rake gem
> rake install_gem
>
> cloned: git://github.com/dchelimsky/rspec-rails.git
> rake gem
> rake install_gem

OK - I know what the cause might be here. Do me a favor and repeat
that process please (using pull instead of clone - I just pushed some
code to github) and let me know if you still have a problem.

Thx
Ebc1e0dfecc4345887f07239f102ad3e?d=identicon&s=25 George Anderson (Guest)
on 2009-02-25 23:26
(Received via mailing list)
I pulled both repos and tried 'rake gem' but got 'permission denied'
'sudo rake gem' worked:

~/work/rspec (master) $ rake gem
(in /Users/george/work/rspec)
/opt/local/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/gempackagetask.rb:13:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.
  Successfully built RubyGem
  Name: rspec
  Version: 1.1.99.9
  File: rspec-1.1.99.9.gem
mv rspec-1.1.99.9.gem pkg/rspec-1.1.99.9.gem
rake aborted!
Permission denied - rspec-1.1.99.9.gem or pkg/rspec-1.1.99.9.gem

(See full trace by running task with --trace)
~/work/rspec (master) $ sudo rake gem
(in /Users/george/work/rspec)
/opt/local/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/gempackagetask.rb:13:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.
  Successfully built RubyGem
  Name: rspec
  Version: 1.1.99.9
  File: rspec-1.1.99.9.gem
mv rspec-1.1.99.9.gem pkg/rspec-1.1.99.9.gem

same with 'rake install_gem' (required sudo)


After re-running "script/generate rspec" it still fails:

it:pdf_revisions!stc_partner_plan> spec spec/models/html_page_spec.rb
/opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
`report_activate_error': RubyGem version error: rspec(1.1.99.9 not =
1.1.11.1) (Gem::LoadError)
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:158:in
`require'
  from ./spec/models/../spec_helper.rb:6
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
   ... 7 levels...
  from
/opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/lib/spec/runner/command_line.rb:9:in
`run'
  from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/bin/spec:4
  from /opt/local/bin/spec:19:in `load'
  from /opt/local/bin/spec:19

I wish I had better news to report.

Thanks for your help,

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george@benevolentcode.com
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-02-25 23:33
(Received via mailing list)
On Wed, Feb 25, 2009 at 3:53 PM, George Anderson
<george@benevolentcode.com> wrote:
>  Version: 1.1.99.9
> 2009.
>
> it:pdf_revisions!stc_partner_plan> spec spec/models/html_page_spec.rb
> /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
> `report_activate_error': RubyGem version error: rspec(1.1.99.9 not =
> 1.1.11.1) (Gem::LoadError)

Is something in your app is requiring version 1.1.11.1 in specific?
Ebc1e0dfecc4345887f07239f102ad3e?d=identicon&s=25 George Anderson (Guest)
on 2009-02-25 23:44
(Received via mailing list)
> Is something in your app is requiring version 1.1.11.1 in specific?

Negative.

That was my thought too, but no such requirement exists.

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george@benevolentcode.com
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-02-26 00:34
(Received via mailing list)
On Wed, Feb 25, 2009 at 4:37 PM, George Anderson
<george@benevolentcode.com> wrote:
>> Is something in your app is requiring version 1.1.11.1 in specific?
>
> Negative.
>
> That was my thought too, but no such requirement exists.

Gotta be coming from somewhere. May not be in your app, but something
somewhere on your machine is requiring rspec-1.1.11.1, otherwise we
wouldn't be getting that error. What about other gems you might be
using?
Ebc1e0dfecc4345887f07239f102ad3e?d=identicon&s=25 George Anderson (Guest)
on 2009-02-26 02:50
(Received via mailing list)
Thanks, David.  That was a good call.

I had these installed:

dchelimsky-rspec (1.1.11.1)
dchelimsky-rspec-rails (1.1.11.1)

They were getting picked up instead of the new 1.1.99.9 gems.

Once I uninstalled them, everything worked.

Thanks again.  I appreciate the support.

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george@benevolentcode.com
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-02-26 03:04
(Received via mailing list)
On Wed, Feb 25, 2009 at 7:48 PM, George Anderson
<george@benevolentcode.com> wrote:
> Thanks, David.  That was a good call.
>
> I had these installed:
>
> dchelimsky-rspec (1.1.11.1)
> dchelimsky-rspec-rails (1.1.11.1)

Glad you got it resolved.

Cheers,
David
This topic is locked and can not be replied to.