Forum: Ruby on Rails can't activate activerecord since already activated

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0839506d6866f4176ba58cb193665c4b?d=identicon&s=25 Pinky Nadane (pinky)
on 2009-02-24 11:33
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
Exiting
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:319:in
`acti
vate': can't activate activerecord (= 2.0.2), already activated
activerecord-2.1
.2] (Gem::Exception)
        from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:31:in `require'
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:510:in `require'
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:355:in `new_constants_in'
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:510:in `require'
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activerec
ord/lib/active_record.rb:44
        from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in `gem_original_require'
        from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in `require'
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:510:in `require'
         ... 35 levels...
        from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/railties/
lib/commands/server.rb:39
        from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in `gem_original_require'
        from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in `require'
        from script/server:3

As given i tried "gem cleanup" though it cleaned the already installed
gems it gives the same error as above...

Could anyone help me out???
80e4cb97cae5c8d745f72337d93fd8f2?d=identicon&s=25 MaD (Guest)
on 2009-02-24 12:19
(Received via mailing list)
check installed gems, frozen rails in vendor and environment-entry for
matching version.

which rails version do you intend to use?
This topic is locked and can not be replied to.