Forum: GNU Radio USRP2 FPGA Programming

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Fc3da6ed7be314cc1a8e662b6241cb28?d=identicon&s=25 Kyle Pearson (Guest)
on 2009-02-23 17:31
(Received via mailing list)
I'm trying to make some modifications to the FPGA on the USRP 2 but
I'm having some problems with the Xilinx project file. When I open the
project, I get an error that the following files are missing:

/home/matt/usrp2/fpga/top/u2_basic.v
/home/matt/usrp2/fpga/control_lib/strobe_gen.v
/home/matt/usrp2/fpga/control_lib/extram_interface.v
/home/matt/usrp2/fpga/coregen/fifo_generator_v4_1.v

Once I get into the project, it appears that other files are missing
(they have a question mark next to them and I can't get to the code).
These files are:
fifo_xlnx_2Kx36_2clk
rx_dcoffset
cordic
cic_strober
hb_strober
hb_interp
small_hb_int
hb_dec
oneshot_2clk
fifo_2clock_casc

Lastly, the fpga selected is the xc3s1500, not the xc3s2000

I'm running Xilinx ISE 9.2i on Windows XP (had trouble installing it
on Ubuntu 8.04 so I just put it on my Windows partition instead) and I
just updated to rev. 10479 off svn. Has anyone else had these issues
or is everyone else fine on Linux and/or ISE 10.1?

Thanks,
Kyle Pearson
3596cfe1d579c65b9babd35e8787977c?d=identicon&s=25 Matt Ettus (Guest)
on 2009-02-23 17:43
(Received via mailing list)
You are using the wrong project.  Use u2_rev3.

Matt
This topic is locked and can not be replied to.