Forum: Ruby on Rails cant seem to run rails console

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Stewart (Guest)
on 2009-02-22 13:14
(Received via mailing list)
Hello,

I cant seem to run my console. I get the following error

~/workspace/testtube $ ./script/console
Loading development environment (Rails 2.2.2)
/usr/local/ruby_test/lib/ruby/site_ruby/1.8/i686-darwin9.6.0/
readline.bundle: dlopen(/usr/local/ruby_test/lib/ruby/site_ruby/1.8/
i686-darwin9.6.0/readline.bundle, 9): Symbol not found:
_rl_filename_completion_function (LoadError)
  Referenced from: /usr/local/ruby_test/lib/ruby/site_ruby/1.8/i686-
darwin9.6.0/readline.bundle
  Expected in: flat namespace
 - /usr/local/ruby_test/lib/ruby/site_ruby/1.8/i686-darwin9.6.0/
readline.bundle
  from /usr/local/ruby_test/lib/ruby/1.8/irb/completion.rb:10
  from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:252:in `require'
  from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:252:in
`load_modules'
  from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:250:in `each'
  from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:250:in
`load_modules'
  from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:21:in `setup'
  from /usr/local/ruby_test/lib/ruby/1.8/irb.rb:54:in `start'
  from /usr/local/ruby_test/bin/irb:13
~/workspace/testtube $

Any ideas?
Conrad Taylor (Guest)
on 2009-02-22 13:26
(Received via mailing list)
On Sat, Feb 21, 2009 at 11:30 PM, Stewart
<stewart.matheson@gmail.com>wrote:

> _rl_filename_completion_function (LoadError)
>        from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:250:in
> `load_modules'
>        from /usr/local/ruby_test/lib/ruby/1.8/irb/init.rb:21:in `setup'
>        from /usr/local/ruby_test/lib/ruby/1.8/irb.rb:54:in `start'
>        from /usr/local/ruby_test/bin/irb:13
> ~/workspace/testtube $
>
> Any ideas?
>

Hi, it appears that you're missing the installation of readline.  Thus,
you'll need to install it before you can continue.

Good luck,

-Conrad
This topic is locked and can not be replied to.