Forum: Ruby ruby-1.9.1 installation on RHEL-4

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7a8edee9ec23cbf518f1816c2c085468?d=identicon&s=25 Vivek Singh (viveksingh)
on 2009-02-21 14:42
Hi,

I am trying to install ruby-1.9.1 on my RHEL-4 system.

make install as su gives me this error:
.
.
.
.
Generating RI...
/home/vivek/churp/ruby-1.9.1-p0/lib/yaml.rb:9:in `require': no such file
to load -- stringio (LoadError)
        from /home/vivek/churp/ruby-1.9.1-p0/lib/yaml.rb:9:in `<top
(required)>'        from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/descriptions.rb:1:in
`require'
        from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/descriptions.rb:1:in `<top
(required)>'
        from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/reader.rb:2:in
`require'
        from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/reader.rb:2:in
`<top (required)>'
        from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/generator/ri.rb:5:in `require'
        from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/generator/ri.rb:5:in `<top
(required)>'
        from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/rdoc.rb:268:in
`require'
        from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/rdoc.rb:268:in
`document'
        from ./bin/rdoc:15:in `<main>'
make: *** [rdoc] Error 1


I have already tried installing ruby-1.8.7 and got some other error. I
hope this forum will help me.

Regards
Vivek
Bec38d63650c8912b6ba9b557fb953b9?d=identicon&s=25 Roger Pack (rogerdpack)
on 2009-02-21 19:19
> I have already tried installing ruby-1.8.7 and got some other error. I
> hope this forum will help me.

I might suggest reposting these to core if you get no responses here.
-=r
4a79f6a97e31b1d13b239e7f52187674?d=identicon&s=25 Joon You (joonee)
on 2009-02-21 20:10
(Received via mailing list)
On Feb 21, 8:42 am, Vivek Singh <viveks.si...@gmail.com> wrote:
> Hi,
>
> I am trying to install ruby-1.9.1 on my RHEL-4 system.
>
> make install as su gives me this error:

This is for CentOS 4.5, but should work with RHEL.  Just ignore the
Apache part and replace the 1.8.6 source with 1.9.1.

http://www.rubyhead.com/2007/12/05/installing-rail...
This topic is locked and can not be replied to.