Forum: Ruby on Rails cannot activate feedtools gem due to frozen rails install

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9f09476d4ff354dc7c8d7676e5974e1e?d=identicon&s=25 Roman Rozinov (rroman81)
on 2009-02-20 22:14
I got feedtools 0.23 installed. I am trying to familiarize with the gem
but when i do "require 'feed_tools'" in script/console of the app, i get
this:
Gem::Exception: can't activate activerecord (>= 1.10.1, runtime),
already activated activerecord-2.1.0

The app has rails 2.1.0 frozen and I have rails 2.2.2 installed on the
system.
How would I troubleshoot this?
6883e5ef03484d4fcef507d7b4f1d243?d=identicon&s=25 Matt Jones (Guest)
on 2009-02-21 20:00
(Received via mailing list)
This is a known issue with the 2.1 series - see
http://rails.lighthouseapp.com:80/projects/8994/tickets/1107
for details. If at all possible, I'd recommend that you upgrade to
2.2, which
fixes the issue.

--Matt Jones

On Feb 20, 4:14 pm, Roman Rozinov <rails-mailing-l...@andreas-s.net>
9f09476d4ff354dc7c8d7676e5974e1e?d=identicon&s=25 Roman Rozinov (rroman81)
on 2009-02-24 23:39
Matt Jones wrote:
> This is a known issue with the 2.1 series - see
> http://rails.lighthouseapp.com:80/projects/8994/tickets/1107
> for details. If at all possible, I'd recommend that you upgrade to
> 2.2, which
> fixes the issue.
>
> --Matt Jones
>
> On Feb 20, 4:14�pm, Roman Rozinov <rails-mailing-l...@andreas-s.net>

Thank you for the info.  That certainly helps.
This topic is locked and can not be replied to.