Forum: NGINX nginx+php5+mysql+phpmyadmin+zend+iconcube -- how to install?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3083abdaa873e8e64b0e9f76ce0ce276?d=identicon&s=25 Dzulhelmi (Guest)
on 2009-02-20 07:28
(Received via mailing list)
Hello people..

I am using latest Ubuntu server edition(8.10)+KDE 4.1

I wanna use this server as my company's local webserver for some our
application and intranet.

During development, i am using Apache as the webserver.

Now i want to use the Nginx

The nginx,php,mysql,phpmyadmin were installed just fine as some of
them were came together with the ubuntu installer.

The problem is, my intranet requires Zend Optimizer and Ioncube loader
to be installed. I know how install it on Apache, but anyone knows how
to install zend and ioncube in nginx?

Please help.
2c6f80fff253635f12c249ef4f116796?d=identicon&s=25 Jim Ohlstein (Guest)
on 2009-02-20 14:51
(Received via mailing list)
These are php extensions so it depends on how you are serving php
scripts
from nginx. If you are using apache-mod_php then you probably don't need
to
do anything. If you are using a separately compiled php-cgi binary and
fastcgi_pass then you need to add them to the php.ini that is in use for
that binary.

Something like this at the end of your php.ini might work:

[Zend]
zend_extension=/path/to/ioncube/ioncube_loader_lin_5.2.so
zend_extension_manager.optimizer=/path/to/Zend/lib/Optimizer-3.3.3
zend_extension_manager.optimizer_ts=/path/to/Zend/lib/Optimizer_TS-3.3.3
zend_optimizer.version=3.3.3
zend_extension=/path/to/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/path/to/Zend/lib/ZendExtensionManager_TS.so

This assumes that you are using linux and php 5.2.x

Jim
3083abdaa873e8e64b0e9f76ce0ce276?d=identicon&s=25 Dzulhelmi (Guest)
on 2009-02-21 03:32
(Received via mailing list)
Hi Jim..

I really hope i can chat with you to ask more about this. I am not
expert in
this.
All i know is, in my linux box i set install apache, php 5 and mysql for
my
works. I really dont know what you mean by fastcgi_pass or
apache-mod_php.

What i know is, even if using apache, i still need to add to the php.ini
for
the ioncube loader to works.
for zend, it will added automatically to the php.ini during zend
installation.

the problem is i dont know how to install these if i am using nginx.
i really like to use nginx but my project requires zend and ioncube.

i really hope someone can guide me in details how to install this.
by the way, does nginx has some sort of kerberos mod to support single
sign
on in windows machine?
This topic is locked and can not be replied to.