Forum: Ruby Building Ruby: Where is libruby1.8.so ?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A9cb9570e8e53f8c807aa37a828f09ec?d=identicon&s=25 Br.Bill (Guest)
on 2009-02-17 02:15
(Received via mailing list)
Ruby version: 1.8.6-p287

Architecture: RedHat enterprise 5.3

Linux den1 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64
x86_64 x86_64 GNU/Linux

I'm no expert on building in Linux, but I have finally managed to
build ruby after banging my head for a couple of days. I can install
it too. I've got it installing into a test area (not a sysadmin). I
can run lots of programs there, but not the ones I need to run, which
are incompatible with the existing 1.8.5 installation.

Unfortunately, although most everything else seems to work fine, I'm
missing libruby1.8.so. Also its lab-mates, libruby.so and libruby18.so.
1.8 .

libruby-static.a is here, drinking all the beer and looking smug.

I need to operate outside of rpms - I do not have the power to install
them anyway.

How do I get the freaking these freaking .so files?

Thanks for anything.

-Br.Bill
Beb77c4602c3cac7a12149431366ed11?d=identicon&s=25 The Higgs bozo (higgsbozo)
on 2009-02-17 02:58
Br.Bill wrote:
>
> Unfortunately, although most everything else seems to work fine, I'm
> missing libruby1.8.so. Also its lab-mates, libruby.so and libruby18.so.
> 1.8 .

./configure --enable-shared
This topic is locked and can not be replied to.