Forum: Rails Engines undefined method `last' for {"user_engine"=>:environment}:Ha

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mehdy M. (Guest)
on 2009-02-16 22:44

[root@localhost coupa-1.5]# ruby -v
ruby 1.8.5 (2006-08-25) [i386-linux]

[root@localhost coupa-1.5]# gem  -v
1.3.1




[root@localhost coupa-1.5]# gem list

*** LOCAL GEMS ***

actionmailer (2.2.2, 1.3.3)
actionpack (2.2.2, 1.13.3)
actionwebservice (1.2.3)
activerecord (2.2.2, 1.15.3)
activeresource (2.2.2)
activesupport (2.2.2, 1.4.2)
acts_as_ferret (0.4.3)
ferret (0.11.6)
mysql (2.7)
rails (2.2.2, 1.2.3)
rake (0.8.3)
rtf (0.1.0)
rubygems-update (1.3.1)
vpim (0.658)


/root/coupa-1.5/config/boot.rb:26:Warning: Gem::SourceIndex#search
support for String patterns is deprecated
rake aborted!
undefined method `last' for {"user_engine"=>:environment}:Hash
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1717:in
`resolve_args'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:9:in
`redefine_task'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:32:in
`redefine_task'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:71
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1255:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1255:in `send'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1255:in `each'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:69
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1851:in
`in_namespace'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:892:in `namespace'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:66
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1851:in
`in_namespace'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:892:in `namespace'
/root/coupa-1.5/config/../vendor/plugins/engines/tasks/engines.rake:62
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
`load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
`load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:in
`new_constants_in'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
`load'
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:8
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:8:in `each'
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:8
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/root/coupa-1.5/Rakefile:10
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in `load'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in
`raw_load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1985:in
`load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1984:in
`load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1969:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19



please help me solve this error
thanks
mehdy
Tony D. (Guest)
on 2009-05-20 05:12
Help!

Getting following error:

rake aborted!
undefined method `last' for {"user_engine"=>:environment}:Hash

I found many posts with similar issue, but no resolution.
Pleas help.
Thank you!
Tony
Daniel S. (Guest)
on 2009-12-09 07:55
Tony Dentamaro wrote:
> Help!
>
> Getting following error:
>
> rake aborted!
> undefined method `last' for {"user_engine"=>:environment}:Hash
>
> I found many posts with similar issue, but no resolution.
> Pleas help.
> Thank you!
> Tony

Hi, Tony.  I'm getting the exact same issue while attempting to install
Coupa Express.  Did you ever get this resolved?  Any pointers?

Thank you!
This topic is locked and can not be replied to.