Forum: wxRuby How to hide horizontal scrollbar in StyledTextCtrl?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Zhimin Z. (Guest)
on 2009-02-12 01:47
Hi,

The StyledTextCtrl sample (samples\scintilla.rb) shows the horizontal
scrollbar by default, even there is no text in the editor.   How to turn
off that option?

PS. The doc for StyledTextEvent is missing,
    http://wxruby.rubyforge.org/doc/styledtextevent

Thanks,
Zhimin
Alex F. (Guest)
on 2009-02-12 11:17
(Received via mailing list)
Zhimin Z. wrote:
> The StyledTextCtrl sample (samples\scintilla.rb) shows the horizontal
> scrollbar by default, even there is no text in the editor.   How to turn
> off that option?
>
stc.use_horizontal_scroll_bar = false
> PS. The doc for StyledTextEvent is missing,
>     http://wxruby.rubyforge.org/doc/styledtextevent
>
Thanks for pointing out the broken link, it should be to:

http://wxruby.rubyforge.org/doc/styledtextevent.html

alex
Zhimin Z. (Guest)
on 2009-02-13 00:37
Alex F. wrote:
> stc.use_horizontal_scroll_bar = false

Thanks, Alex.

What I really wanted was to show horizontal scroll bar as needed,
following your reply, I added

      set_scroll_width(100)

That seemed solved my problem.

The default scroll width (calling get_scroll_width) was set 2000.

Regards,
Zhimin
This topic is locked and can not be replied to.