Forum: NGINX nginx-0.7.34

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
5640e332954fc0006aea97a155ce0afd?d=identicon&s=25 Igor Sysoev (Guest)
on 2009-02-10 18:07
(Received via mailing list)
Changes with nginx 0.7.34                                        10 Feb
2009

    *) Feature: the "off" parameter of the "if_modified_since"
directive.

    *) Feature: now nginx sends an HELO/EHLO command after a XCLIENT
       command.
       Thanks to Maxim Dounin.

    *) Feature: Microsoft specific "AUTH LOGIN with User Name" mode
support
       in mail proxy server.
       Thanks to Maxim Dounin.

    *) Bugfix: in a redirect rewrite directive original arguments were
       concatenated with new arguments by an "?" rather than an "&";
       the bug had appeared in 0.1.18.
       Thanks to Maxim Dounin.

    *) Bugfix: nginx could not be built on AIX.
1d7e58690643fef4a92750ff39f4c56c?d=identicon&s=25 Kevin Worthington (Guest)
on 2009-02-11 00:28
(Received via mailing list)
Once compiled, the server version is listed as 0.7.33. Is there a simple
fix?

--
Kevin Worthington
2c6f80fff253635f12c249ef4f116796?d=identicon&s=25 Jim Ohlstein (Guest)
on 2009-02-11 02:25
(Received via mailing list)
Nginx version is defined in /path/to/nginx-0.7.34/src/core/nginx.h in
line 11.

line 11 : #define NGINX_VERSION      "0.7.34"
line 12 : #define NGINX_VER          "nginx/" NGINX_VERSION

It is correct in my download of 0.7.34 and the header is correct as
well.


Jim
1d7e58690643fef4a92750ff39f4c56c?d=identicon&s=25 Kevin Worthington (Guest)
on 2009-02-11 02:47
(Received via mailing list)
Thanks for pointing me to that file, Jim. Mine also had 0.7.34 in
nginx.h - I'm not sure what I did that caused the header to say
0.7.33...

--
Kevin Worthington
52ec6f2d0206837902876df1c72e906d?d=identicon&s=25 Tomasz Pajor (Guest)
on 2009-02-11 10:07
(Received via mailing list)
did not restart?
1d7e58690643fef4a92750ff39f4c56c?d=identicon&s=25 Kevin Worthington (Guest)
on 2009-02-11 14:46
(Received via mailing list)
No, my build system was not running Nginx. I built the package and
transferred it to a test system, after uninstalling it there. Tried
the entire build process over a few times and still get the wrong
version. I am going to try to rebuild on a separate system today to
try to isolate this problem.
--
Kevin Worthington
1d7e58690643fef4a92750ff39f4c56c?d=identicon&s=25 Kevin Worthington (Guest)
on 2009-02-12 01:19
(Received via mailing list)
Nginx 0.7.34 with most modules compiled in by default, is now
available: http://cli.gs/734
--
Kevin Worthington




On Wed, Feb 11, 2009 at 8:37 AM, Kevin Worthington
This topic is locked and can not be replied to.