Forum: GNU Radio New USRP2 Warning Message

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3d593de8acbe2510722af740d8668352?d=identicon&s=25 Firas A. (Guest)
on 2009-02-08 13:36
(Received via mailing list)
Hi,

FYI, When I upgraded my gnuradio rev from 10368 to 10404, I got the
following warnning message when I run usrp2_fft.py (although the program
ran
normally):

usrp2::ctor reset_db failed


My OS is Ubuntu 8.1, USRP2 was fitted with RFX900 daughterboard.


Best Regards,

Firas



--
View this message in context:
http://www.nabble.com/New-USRP2-Warning-Message-tp...
Sent from the GnuRadio mailing list archive at Nabble.com.
D0072e69d706bb3ca211d33a1b536e2c?d=identicon&s=25 Johnathan Corgan (Guest)
on 2009-02-08 16:46
(Received via mailing list)
On Sun, Feb 8, 2009 at 4:33 AM, Firas A. <firasmail2000@yahoo.com>
wrote:

> FYI, When I upgraded my gnuradio rev from 10368 to 10404, I got the
> following warnning message when I run usrp2_fft.py (although the program ran
> normally):
>
> usrp2::ctor reset_db failed

Thanks.  This was a recent addition to libusrp2 to reset the USRP2
daughterboard parameters to power on defaults during host software
initialization.

Do you get this every time you run usrp2_fft.py?  Can you try
usrp2_siggen.py or usrp2_rx_cfile.py?

Johnathan
3d593de8acbe2510722af740d8668352?d=identicon&s=25 Firas Abbas (Guest)
on 2009-02-08 17:38
(Received via mailing list)
Hi,

> On Sun, 2/8/09, Johnathan Corgan <jcorgan@corganenterprises.com> wrote:
>
> Do you get this every time you run usrp2_fft.py?  Can you try
> usrp2_siggen.py or usrp2_rx_cfile.py?
>
> Johnathan


I get this message every time I try to run usrp2_fft.py. for the others,
I will try tomorrow.

Also, when I try to use tb.start, tb.wait & tb.stop with usrp2, I get
the following warning :

usrp2: channel 0 already streaming

When I get this message, usrp2 stops streaming. I got the same behavior
when I use tb.lock and tb.unlock (the flowgraph runs only for one time).


Best Regards,


Firas
D0072e69d706bb3ca211d33a1b536e2c?d=identicon&s=25 Johnathan Corgan (Guest)
on 2009-02-08 17:44
(Received via mailing list)
On Sun, Feb 8, 2009 at 8:36 AM, Firas Abbas <firasmail2000@yahoo.com>
wrote:

> I get this message every time I try to run usrp2_fft.py. for the others, I will try 
tomorrow.

Thanks.

> Also, when I try to use tb.start, tb.wait & tb.stop with usrp2, I get the following 
warning :
>
> usrp2: channel 0 already streaming
>
> When I get this message, usrp2 stops streaming. I got the same behavior when I use 
tb.lock and tb.unlock (the flowgraph runs only for one time).

Did this start occurring at the same time as the reset_db() failure,
or has it been going on longer?

Johnathan
3d593de8acbe2510722af740d8668352?d=identicon&s=25 Firas Abbas (Guest)
on 2009-02-08 18:11
(Received via mailing list)
Hi,

> On Sun, 2/8/09, Johnathan Corgan <jcorgan@corganenterprises.com> wrote:
>
>
> Did this start occurring at the same time as the reset_db() failure,
> or has it been going on longer?
>
> Johnathan


No. It was existed from an older revisions.


Best Regards,

Firas
3d593de8acbe2510722af740d8668352?d=identicon&s=25 Firas Abbas (Guest)
on 2009-02-09 07:12
(Received via mailing list)
Hi,


> On Sun, 2/8/09, Johnathan Corgan <jcorgan@corganenterprises.com> wrote:
>
> Do you get this every time you run usrp2_fft.py?  Can you
> try usrp2_siggen.py or usrp2_rx_cfile.py?
>
> Johnathan


Yes, with usrp2_siggen.py or usrp2_rx_cfile.py, I got this message too.


Best Regards,

Firas
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2009-02-09 17:17
(Received via mailing list)
On Sun, Feb 08, 2009 at 10:11:05PM -0800, Firas Abbas wrote:
> Yes, with usrp2_siggen.py or usrp2_rx_cfile.py, I got this message too.
>
>
> Best Regards,
> Firas

For the first part of the question, something about reset_db, I think
you need to update, build and reinstall the f/w on the SDCARD since
internally, we now use a new (internal) method to handle some things.

Eric
3d593de8acbe2510722af740d8668352?d=identicon&s=25 Firas Abbas (Guest)
on 2009-02-09 19:07
(Received via mailing list)
Hi,

> On Mon, 2/9/09, Eric Blossom <eb@comsec.com> wrote:
>
> For the first part of the question, something about
> reset_db, I think you need to update, build and reinstall the f/w on the
> SDCARD since internally, we now use a new (internal) method to handle
> some things.
>
> Eric

I think my SD revision is 9935 or 9939. I will try tomorrow to upgrade
to latest firmware.

Best Regards,

Firas
879e080c174638d3d64fcaee916ef1dc?d=identicon&s=25 Shih-shen Lu (leeraphael)
on 2009-03-08 16:10
Firas Abbas wrote:
> Hi,
>
>> On Mon, 2/9/09, Eric Blossom <eb@comsec.com> wrote:
>>
>> For the first part of the question, something about
>> reset_db, I think you need to update, build and reinstall the f/w on the
>> SDCARD since internally, we now use a new (internal) method to handle
>> some things.
>>
>> Eric
>
> I think my SD revision is 9935 or 9939. I will try tomorrow to upgrade
> to latest firmware.
>
> Best Regards,
>
> Firas

Hello,

Do you solve the problem??
I update the firmware to u2_rev3_ise10.1sp3_r10524.bin.
When I run usrp2/host/apps/test.sh, it still show the error message.

Does anybody has solved the problem?


Thanks.


Shih-Shen
879e080c174638d3d64fcaee916ef1dc?d=identicon&s=25 Shih-shen Lu (leeraphael)
on 2009-03-08 16:17
Sorry, it can work. I miss updating the txrx-edk10.1-r10524.bin.

Thanks.


> Hello,
>
> Do you solve the problem??
> I update the firmware to u2_rev3_ise10.1sp3_r10524.bin.
> When I run usrp2/host/apps/test.sh, it still show the error message.
>
> Does anybody has solved the problem?
>
>
> Thanks.
>
>
> Shih-Shen
This topic is locked and can not be replied to.