Forum: Ruby can not install RubyGems (uninitialized constant YAML::Syck::DefaultLoader (NameError))

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D5df9fcd7ef4c3c937435d7d6adeab2a?d=identicon&s=25 Greg Hauptmann (Guest)
on 2009-02-06 22:07
(Received via mailing list)
Hi,

I think I've upset my ruby/gems on my Redhat Linux box (I did an
apt-get install ruby-libs).  So I've installed again Ruby from source
(did get some warnings - see previous post), and then tried to install
RubyGem however I get the following error.  Any ideas?  Anything else
I can post to help?

[root@home rubygems-1.3.1]# ruby ./setup.rb
/usr/lib/ruby/1.8/yaml.rb:14: uninitialized constant
YAML::Syck::DefaultLoader (NameError)
        from ./lib/rubygems/config_file.rb:7:in `require'
        from ./lib/rubygems/config_file.rb:7
        from ./lib/rubygems.rb:882:in `require'
        from ./lib/rubygems.rb:882
        from ./setup.rb:22:in `require'
        from ./setup.rb:22

Some addition config info:
[root@home ~]#
[root@home ~]# ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux]
[root@home ~]# which ruby
/usr/local/bin/ruby
[root@home ~]# which gem
/usr/bin/gem
[root@home ~]# gem -v
/usr/lib/ruby/1.8/yaml.rb:14: uninitialized constant
YAML::Syck::DefaultLoader (NameError)
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/config_file.rb:7
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:8
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/bin/gem:9


thanks
D5df9fcd7ef4c3c937435d7d6adeab2a?d=identicon&s=25 Greg Hauptmann (Guest)
on 2009-02-06 22:12
(Received via mailing list)
PS.  I noted I have a few matches for 'ruby'.  Not sure if this is
significant re my problem

# find / -name ruby
/usr/local/bin/ruby
/usr/local/lib/ruby
/usr/bin/ruby
/usr/lib/swig1.3/ruby
/usr/lib/ruby
/root/source/redmine-0.7/vendor/plugins/coderay-0.7.6.227/lib/coderay/scanners/ruby

# which ruby
/usr/local/bin/ruby

2009/2/7 Greg Hauptmann <greg.hauptmann.ruby@gmail.com>:
This topic is locked and can not be replied to.