Forum: Ruby on Rails rail's compatibility problem

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
342ddf40757f8320a364381d1ae04d3f?d=identicon&s=25 Jack Wu (babyboss)
on 2009-02-04 22:18
I did 'Jruby script/generate controller home index', and I got "Rails
requires RubyGems >= 1.3.1 (you have 1.2.0). Please 'gem update
--system' and try again" message. I follwed, and did 'gem update
--system', but it tells me there is nothing to update. My rails version
is 2.2.2, I tried to install lower version, but did 'gem query --remote
--name-matches rails', only rails 2.2.2 version comes up, which is the
one I am having. Thank you very much.
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2009-02-04 22:50
(Received via mailing list)
On 4 Feb 2009, at 21:18, Jack Wu wrote:

> one I am having. Thank you very much.
rubygems 1.2 and 1.1 can have problems updating themselves (

3131fcea0a711e5ad89c8d49cc9253b4?d=identicon&s=25 Julian Leviston (Guest)
on 2009-02-05 01:23
(Received via mailing list)
Is it because you have jruby AND ruby? Therefore also two gems?

Learn rails:

On 05/02/2009, at 8:18 AM, Jack Wu <>
This topic is locked and can not be replied to.