Forum: GNU Radio checking for boost >= 1.35... no

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
85ffd97bae0e78056e1d06312744d7d1?d=identicon&s=25 feldmaus (Guest)
on 2009-01-31 13:52
(Received via mailing list)
Hi All,


i tried to compile gnuradio from trunk(2009.Jan.28) and
got Problems with the boost Package.
My System is openSuse 11.1.

The following Message appears:
################################################################################
checking for boost >= 1.35... no

configure: error: we could not detect the boost libraries (version 1.35
or
higher).

If you are sure you have boost installed, then check your version number
looking
in <boost/version.hpp>.
error: Bad exit status from /var/tmp/rpm-tmp.92103 (%build)
################################################################################

Wherfore do i need Boost ?
I tried to use the Option <--with-boost=/usr/include/boost> but without
success.
I installed boost and boost-devel !
Do you have further instructions for me?


Here is a List of all Packages i installed:
python-cheetah-2.0.1-3.4
python-lxml-2.0.5-1.7
python-numpy-1.2.1-6.1
LabPlot-debugsource-1.6.0.2-17.7
LabPlot-1.6.0.2-17.7
gsl-1.11-1.38
libusbpp-0_1-4-0.1.12-136.10
libsigc++2-2.2.2-40.25
xmlto-0.0.18-182.24
python-wxGTK-2.8.8.1-1.48
wxGTK-compat-2.8.8.1-1.48
sdcc-2.8.0-2
libboost_filesystem1_36_0-1.36.0-9.5
wxGTK-2.8.8.1-1.48
sdcc-common-2.8.0-2
fftw3-threads-3.1.2-109.30
swig-1.3.36-2.6
libboost_graph1_36_0-1.36.0-9.5
libboost_iostreams1_36_0-1.36.0-9.5
libboost_math1_36_0-1.36.0-9.5
libboost_program_options1_36_0-1.36.0-9.5
libboost_python1_36_0-1.36.0-9.5
libboost_regex1_36_0-1.36.0-9.5
libboost_serialization1_36_0-1.36.0-9.5
libboost_system1_36_0-1.36.0-9.5
libboost_test1_36_0-1.36.0-9.5
libboost_thread1_36_0-1.36.0-9.5
libcppunit-1_12-0-1.12.0-2.93
guile-1.8.5-22.23
python-gtk-2.12.1-63.3
gtk2-2.14.4-8.1
alsa-1.0.18-8.7
udev-128-9.3
python-numeric-24.2-195.8
fftw3-3.1.2-109.30
libboost_signals1_36_0-1.36.0-9.5
python-2.6.0-2.16
python-base-2.6.0-2.12
alsa-oss-1.0.17-1.37
SDL-1.2.13-104.1
libusb-0_1-4-0.1.12-136.10
SDL-devel-1.2.13-104.1
alsa-devel-1.0.18-8.7
gsl-devel-1.11-1.38
libusb-devel-0.1.12-136.10
wxGTK-devel-2.8.8.1-1.48
boost-devel-1.36.0-9.5
fftw3-devel-3.1.2-109.30
libcppunit-devel-1.12.0-2.93
guile-devel-1.8.5-22.23
python-gtk-devel-2.12.1-63.3
python-devel-2.6.0-2.12
automake-1.10.1-4.264
autoconf-2.63-1.97
libtool-2.2.6-1.20

As you can see there should be all what i need.

Regards Markus
85ffd97bae0e78056e1d06312744d7d1?d=identicon&s=25 feldmaus (Guest)
on 2009-01-31 14:43
(Received via mailing list)
To compile <gnuradio> is used the following Option:
./configure --enable-gr-wxgui --enable-grc --enable-usrp \
--enable-gr-usrp --enable-gr-audio-alsa --enable-gnuradio-examples \
--enable-gnuradio-core --enable-gr-audio-oss
85ffd97bae0e78056e1d06312744d7d1?d=identicon&s=25 feldmaus (Guest)
on 2009-01-31 15:22
(Received via mailing list)
I installed the Package <gcc-c++> and solve this Problem,
but no i am getting this:
checking whether the boost::thread includes are available... yes
configure: error: Could not link against libboost_thread!


Anyone has an idea ?
E16be4811324adf8f26be26d77e9d29d?d=identicon&s=25 Bob McGwier (Guest)
on 2009-01-31 18:42
(Received via mailing list)
Markus:

In the root directory of the trunk, there is a README file that looks
suspiciously like it will be the answer to your question. (as in
README.building-boost)

Good luck
Bob


feldmaus wrote:
>
> success.
> gsl-1.11-1.38
> swig-1.3.36-2.6
> libcppunit-1_12-0-1.12.0-2.93
> alsa-oss-1.0.17-1.37
> guile-devel-1.8.5-22.23
>
>
>
> _______________________________________________
> Discuss-gnuradio mailing list
> Discuss-gnuradio@gnu.org
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>
>


--
(Co)Author: DttSP, Quiktrak, PowerSDR, GnuRadio
Member: ARRL, AMSAT, AMSAT-DL, TAPR, Packrats,
NJQRP, QRP ARCI, QCWA, FRC.
"It is human nature to think wisely and act in
an absurd fashion.", Anatole France.
A725014f091bcd9e8ff16e9f2a0d7e20?d=identicon&s=25 Stefan Bruens (Guest)
on 2009-01-31 23:59
(Received via mailing list)
On Saturday 31 January 2009 15:20:58 feldmaus wrote:
> I installed the Package <gcc-c++> and solve this Problem,
> but no i am getting this:
> checking whether the boost::thread includes are available... yes
> configure: error: Could not link against libboost_thread!

I am using the boost packages of the standard openSUSE 11.1 repository,
so
in general, it should work.

These are the packages I have installed from boost (according to "zypper
se -i boost"):
S | Name                           | Summary
| Type
--+--------------------------------+-----------------------------------------+--------
i | boost-devel                    | Development package for Boost C++
| package
i | boost-license                  | Boost License
| package
i | libboost_date_time1_36_0       | Boost::Date.Time Runtime libraries
| package
i | libboost_filesystem1_36_0      | Boost::Filesystem Runtime Libraries
| package
i | libboost_graph1_36_0           | Boost::Graph Runtime Libraries
| package
i | libboost_iostreams1_36_0       | Boost::IOStreams Runtime Libraries
| package
i | libboost_math1_36_0            | Boost::Math Runtime Libraries
| package
i | libboost_mpi1_36_0             | Boost::MPI Runtime libraries
| package
i | libboost_program_options1_36_0 | Boost::ProgramOptions Runtime
libraries | package
i | libboost_python1_36_0          | Boost::Python Runtime Libraries
| package
i | libboost_regex1_36_0           | The Boost::Regex runtime library
| package
i | libboost_serialization1_36_0   | Boost::Serialization Runtime
Libraries  | package
i | libboost_signals1_36_0         | Boost::Signals Runtime Libraries
| package
i | libboost_system1_36_0          | Boost::System Runtime Libraries
| package
i | libboost_test1_36_0            | Boost::Test Runtime Libraries
| package
i | libboost_thread1_36_0          | Boost::Thread Runtime Libraries
| package
i | libboost_wave1_36_0            | Boost::Wave Runtime Libraries
| package

Have you installed libboost_thread1_36_0 (shoud be a dependency of
boost-devel, anyway, so most probably, yes).

To get some more info from configure, have a look into config.log,
search
for boost::thread.

Regards,

Stefan
287db267f16cb26430934ea36168e6b3?d=identicon&s=25 Mattias Kjellsson (Guest)
on 2009-02-01 02:03
(Received via mailing list)
Stefan Bruens wrote:
> On Saturday 31 January 2009 15:20:58 feldmaus wrote:
>
>> I installed the Package <gcc-c++> and solve this Problem,
>> but no i am getting this:
>> checking whether the boost::thread includes are available... yes
>> configure: error: Could not link against libboost_thread!
>>
Boost used to present a problem for me as well, but since I began to use
the "--with-boost-libdir"- flag (or what was it? Check with "configure
--help") while configuring gnuradio it sorted itself out. This actually
requires one to know where boosts libraries are located... I think
"find" or "slocate" are good candidates for finding that out.

Hopes this gets you going.
//Mattias Kjellsson
85ffd97bae0e78056e1d06312744d7d1?d=identicon&s=25 feldmaus (Guest)
on 2009-02-02 10:56
(Received via mailing list)
Stefan Bruens <stefan.bruens <at> rwth-aachen.de> writes:
> I am using the boost packages of the standard openSUSE 11.1 repository, so
> in general, it should work.
Thanks for your reply.

I removed the Option <--with-boost=/usr/include/boost> and
solved the Problem. So my whole Options i used to compile
was:
./configure --enable-gr-wxgui --enable-grc --enable-usrp \
--enable-gr-usrp --enable-gr-audio-alsa --enable-gnuradio-examples \
--enable-gnuradio-core --enable-gr-audio-oss

Thats it. :-)

Regards Markus
This topic is locked and can not be replied to.