Forum: NGINX Using nginx as a frontend for apache2 serving wordpress w/ super-cache

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D2d314970c6ac9aa0dd3f4ecf97bbe20?d=identicon&s=25 Dieter Zinke (Guest)
on 2009-01-24 10:58
(Received via mailing list)
I am trying to setup nginx as a frontend for apache2 to serve Wordpress
with super-cache. I don' t want to use this for a production server,
only to speed up my old Athlon 1100 workstation, which moves sometimes
into swapping while using the wordpress admin panel. This is my
workarround:

http://home.arcor.de/nhz6/nginx/default
http://home.arcor.de/nhz6/nginx/nginx.conf

Trying to access http://example.com redirects me to
http://example.com:8080, but the serving of static files by nginx doesn'
t work and i get 301 errors. Trying to access
http://example.com/wp-content/themes/yaml-karo/ima...
redirects me to http://example.com:8080/. Maybe i am missing something
or a typo, don' t know.

http://home.arcor.de/nhz6/nginx/error.log
http://home.arcor.de/nhz6/nginx/access.log (empty)
http://home.arcor.de/nhz6/nginx/example.com.error.log
http://home.arcor.de/nhz6/nginx/example.com.access.log

It is also bad that only very few nginx --> apache2 howtos exists and
those i' ve found use very very different ways and all are missing the
apache2 part. Seems to be very simple. I am for example unsure with
these settings

<IfModule prefork.c>
    StartServers 5
    MinSpareServers 2
    MaxSpareServers 5
    MaxClients 50
    MaxRequestsPerChild 0
</IfModule>

I ve also set KeepAlive to Off. Maybe i can modify other options, but i
don' t know. Appreciate any help. Thanks.
A8108a0961c6087c43cda32c8616dcba?d=identicon&s=25 Maxim Dounin (Guest)
on 2009-01-25 10:43
(Received via mailing list)
Hello!

On Sat, Jan 24, 2009 at 01:45:48AM -0800, Dieter Zinke wrote:

> I am trying to setup nginx as a frontend for apache2 to serve Wordpress with 
super-cache. I don' t want to use this for a production server, only to speed up my old 
Athlon 1100 workstation, which moves sometimes into swapping while using the wordpress 
admin panel. This is my workarround:
>
> http://home.arcor.de/nhz6/nginx/default
> http://home.arcor.de/nhz6/nginx/nginx.conf
>
> Trying to access http://example.com redirects me to http://example.com:8080, but the 
serving of static files by nginx doesn' t work and i get 301 errors. Trying to access 
http://example.com/wp-content/themes/yaml-karo/ima... redirects me to 
http://example.com:8080/. Maybe i am missing something or a typo, don' t know.

Serving static from nginx doesnt work due to the following code in
your server configuration:

  # all other requests go to Wordpress
  if (!-e $request_filename) {
  rewrite . /index.php last;
  }

It's done at server level and tests file existence without
root specified.

Maxim Dounin
This topic is locked and can not be replied to.