Forum: GNU Radio Flarging big FFTs

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
558c40b97bd1af8d912424757714bda9?d=identicon&s=25 Marcus D. Leech (Guest)
on 2009-01-23 19:02
(Received via mailing list)
I can't use FFTs larger than about 180000 bins without getting "shared
memory allocation" errors in Gnu Radio.

Is there an easy fix for this?

For SETI work, being able to (for example) compute an 8 million point
FFT for an 8Msps signal gives you 1Hz
  resolution.  But I can't seem to get anywhere near this without the
allocator griping at me.

--
Marcus Leech
Principal Investigator, Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2009-01-23 19:24
(Received via mailing list)
On Fri, Jan 23, 2009 at 01:01:24PM -0500, Marcus D. Leech wrote:
> I can't use FFTs larger than about 180000 bins without getting "shared
> memory allocation" errors in Gnu Radio.
>
> Is there an easy fix for this?
>
> For SETI work, being able to (for example) compute an 8 million point
> FFT for an 8Msps signal gives you 1Hz
>   resolution.  But I can't seem to get anywhere near this without the
> allocator griping at me.
>

Hi Marcus,

You need to bump up the shared memory maximum segment size.
You can do this with the sysctl command.  On some systems there's also
an /etc/sysctl.conf file.  The defaults appear to depend on your
distribution.   The parameter you want to increase is kernel.shmmax.

  [eb@cyan trunk]$ sudo sysctl -a | grep shm
  kernel.shmmax = 268435456
  kernel.shmall = 2097152
  kernel.shmmni = 4096
  vm.hugetlb_shm_group = 0

The output above is from an x86 Fedora 9 system.  It's pretty big by
default.

See also

 $ man sysctl
 $ man sysctl.conf

 http://bugzilla.kernel.org/show_bug.cgi?id=11381

Eric
This topic is locked and can not be replied to.