Forum: Italian Ruby user group rubygems.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
B0f6d8efcf671ea3163449e231264cc4?d=identicon&s=25 Mauro (Guest)
on 2009-01-21 20:10
(Received via mailing list)
Anziche' installarmi rubygem dal tar scaricato da rubyforge, preferisco
installarmi il deb di debian, tanto la versione e' la stessa.
Siccome pero' avevo installato in precendenza rubygem dal tar col
comando
ruby setup.rb, come faccio adesso a disinstallare tutti i files che il
suddetto comando mi ha installato?
Ho visto ad esempio che c'e' qualcosa in /usr/local/lib/site_ruby.
Devo cancellare tutto a mano?
Spero di no.
8768bcdbda1adf80e4da6744268868af?d=identicon&s=25 Pietro Giorgianni (giorgian)
on 2009-01-21 21:21
(Received via mailing list)
Il 21 gennaio 2009 20.09, Mauro <mrsanna1@gmail.com> ha scritto:
> Anziche' installarmi rubygem dal tar scaricato da rubyforge, preferisco
> installarmi il deb di debian, tanto la versione e' la stessa.
> Siccome pero' avevo installato in precendenza rubygem dal tar col comando
> ruby setup.rb, come faccio adesso a disinstallare tutti i files che il
> suddetto comando mi ha installato?
> Ho visto ad esempio che c'e' qualcosa in /usr/local/lib/site_ruby.
> Devo cancellare tutto a mano?
> Spero di no.

temo che la risposta sia: più o meno
sì.
non ho sottomano il targz di ruby, ma forse provando le opzioni di
setup.rb c'è modo di scoprire l'elenco dei file che vengono
creati/copiati.

se sì, allora c'è modo di cancellarli: se il comando xxx elenca i file
che verrebbero installati, xxx | xargs rm -f li cancella.
(nella peggiore delle ipotesi: se setup.py, all'installazione, lista i
file man mano che li crea, puoi prendere quella lista e cancellare i
file.)
C01072ccffb1f2d23f8b5f686e5b106a?d=identicon&s=25 gabriele renzi (Guest)
on 2009-01-21 23:30
(Received via mailing list)
attenzione alla versione debian di rubygems, se non ricordo male
è effettivmente modificata in modo da non funzionare cone l'originale (ad
esempio, è impossibile fare update --system). D'altronde, potrei ricordare
male, ma magari controlla :)

 --
blog it: http://riffraff.blogsome.com
blog en: http://www.riffraff.info
8ae7f93e6bb17053070baaef18e4d379?d=identicon&s=25 Michele Franzin (Guest)
on 2009-01-21 23:38
(Received via mailing list)
On Wed, Jan 21, 2009 at 11:30 PM, gabriele renzi <surrender_it@yahoo.it>
wrote:
> attenzione alla versione debian di rubygems, se non ricordo male è effettivmente 
modificata in modo da non funzionare cone l'originale (ad esempio, è impossibile fare 
update --system). D'altronde, potrei ricordare male, ma magari controlla :)

quella di ubuntu (derivata da debian) funziona esattamente così
quella di ubuntu

m.
8768bcdbda1adf80e4da6744268868af?d=identicon&s=25 Pietro Giorgianni (giorgian)
on 2009-01-22 08:39
(Received via mailing list)
2009/1/21 gabriele renzi <surrender_it@yahoo.it>:
> attenzione alla versione debian di rubygems, se non ricordo male è effettivmente 
modificata in modo da non funzionare cone l'originale (ad esempio, è impossibile fare 
update --system). D'altronde, potrei ricordare male, ma magari controlla :)

confermo.

sia in testing che in unstable c'è la 1.2.qualcosa, in stable non lo
so. per la 1.3.1 devi aggiungere tra i source il ramo experimental.
8f2535597ab73716718bf59187a38a25?d=identicon&s=25 FEj (Guest)
on 2009-01-22 09:14
(Received via mailing list)
On Thu, Jan 22, 2009 at 8:39 AM, Pietro Giorgianni <giorgian@gmail.com>
wrote:
> 2009/1/21 gabriele renzi <surrender_it@yahoo.it>:
>> attenzione alla versione debian di rubygems, se non ricordo male è effettivmente 
modificata in modo da non funzionare cone l'originale (ad esempio, è impossibile fare 
update --system). D'altronde, potrei ricordare male, ma magari controlla :)
>
> confermo.
>
> sia in testing che in unstable c'è la 1.2.qualcosa, in stable non lo
> so. per la 1.3.1 devi aggiungere tra i source il ramo experimental.

Ecco la lista delle versioni di rubygems per debian:
http://packages.debian.org/search?keywords=rubygems

Per installare la versione da experimental usa il comando:
apt-get -t experimental rubygems


Ciao

--
FEj

"Go and spread the free software. Happy hacking!" - RMS
B0f6d8efcf671ea3163449e231264cc4?d=identicon&s=25 Mauro (Guest)
on 2009-01-22 09:37
(Received via mailing list)
2009/1/21 gabriele renzi <surrender_it@yahoo.it>

> attenzione alla versione debian di rubygems, se non ricordo male è
> effettivmente modificata in modo da non funzionare cone l'originale (ad
> esempio, è impossibile fare update --system). D'altronde, potrei ricordare
> male, ma magari controlla :)


Hai ragione, ritorno al rubygem di rubyforge :)
C01072ccffb1f2d23f8b5f686e5b106a?d=identicon&s=25 gabriele renzi (Guest)
on 2009-01-22 22:35
(Received via mailing list)
> quella di ubuntu (derivata da debian) funziona esattamente così
> quella di ubuntu
ah, grazie, mi scuso per l'imprecisione.
Dev essermi confuso tra il paccchetto di ubuntu e la posizione dei
packager debian che non amano rubygems
B0f6d8efcf671ea3163449e231264cc4?d=identicon&s=25 Mauro (Guest)
on 2009-01-22 22:40
(Received via mailing list)
2009/1/22 gabriele renzi <surrender_it@yahoo.it>

> > è impossibile fare update --system). D'altronde, potrei ricordare male,
> ma
> > magari controlla :)
> >
> > quella di ubuntu (derivata da debian) funziona esattamente così
> > quella di ubuntu
>
> ah, grazie, mi scuso per l'imprecisione.
> Dev essermi confuso tra il paccchetto di ubuntu e la posizione dei packager
> debian che non amano rubygems
>
> Funziona allo stesso modo anche rubygems di debian, percio' ho
disinstallato il pacchetto e installato rubygems scaricato da rubyforge.
This topic is locked and can not be replied to.