Forum: Ruby on Rails rake db:migrate and mysql

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7da3d795630c59f6f02497cf1a316c0d?d=identicon&s=25 Robert Todd (rptodd)
on 2009-01-21 00:13
Hi, when I run this it aborts with an access denied message and
usepassword = NO

How do I change this to either not require a password, or allow me to
set the password in the rake command line execution (it's set in the
database.yml file, but rake isn't using it)
Bb0bf716c0e721d2b54ced2ba202f66b?d=identicon&s=25 jthompson (Guest)
on 2009-01-21 10:20
(Received via mailing list)
I'm not sure about setting the password at the execution, but I would
double check the password in the yml file first. Also check with your
database and make sure the username/password combination you're using
matches the database's. Seems simple but its happened to me before.
7da3d795630c59f6f02497cf1a316c0d?d=identicon&s=25 Robert Todd (rptodd)
on 2009-01-21 18:04
jthompson wrote:
> I'm not sure about setting the password at the execution, but I would
> double check the password in the yml file first. Also check with your
> database and make sure the username/password combination you're using
> matches the database's. Seems simple but its happened to me before.

Thanks for the reply.  I had typoed the word password parameter in the
.yml file
This topic is locked and can not be replied to.