Forum: Ruby on Rails mongrel error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
738429ce64c60f95e64f8f393976a29f?d=identicon&s=25 amrita (Guest)
on 2009-01-15 03:59
(Received via mailing list)
Hi,

I have my rails application deployed on a 32-bit machine and I'm
trying to move it to a 64-bit machine. Thing is, I have rails and gem
installed in my home directory. I re-installed mongrel and
mongrel_cluster on the 64-bit machine. But when I issue any
mongrel_rails command, it hangs until I interrupt it with a ctrl+c,
upon which I get the following dump:

me@64bitmachine$ mongrel_rails -
** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
/home/me/mygems/gems/mongrel-1.1.5/bin/../lib/mongrel/gems.rb:8:in
`require': Interrupt
        from /home/me/mygems/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:
17
        from /home/me/rubygems/lib/rubygems/custom_require.rb:27:in
`gem_original_require'
        from /home/me/rubygems/lib/rubygems/custom_require.rb:27:in
`require'
        from /home/me/mygems/gems/mongrel-1.1.5/bin/mongrel_rails:11
        from /home/me/mygems/bin/mongrel_rails:19:in `load'
        from /home/me/mygems/bin/mongrel_rails:19

Does anyone have an idea as to what is going wrong here?

Thanks!
A91bd6cef23eb3516245a092e196c4da?d=identicon&s=25 Maurício Linhares (mauricio)
on 2009-01-15 13:22
(Received via mailing list)
Are you running the latest ruby for you environment? What is you OS?
-
Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) | http://blog.codevader.com/
(en)
738429ce64c60f95e64f8f393976a29f?d=identicon&s=25 amrita (Guest)
on 2009-01-15 17:01
(Received via mailing list)
OS is Debian Linux. Ruby version is 1.8.5 [x86_64-linux]

Thanks!

On Jan 15, 4:21 am, "Maurício Linhares" <mauricio.linha...@gmail.com>
9cf6e7f81d4339295b86e5fb7d7df49b?d=identicon&s=25 Vishwanath Nayak (nayak)
on 2009-01-15 19:53
(Received via mailing list)
Hi,

Shift to Ruby 1.8.7 (http://www.ruby-lang.org/en/downloads/) rather than
the
inbuilt 1.8.5 this should solve your problem

NAYAK

On Thu, Jan 15, 2009 at 9:31 PM, amrita <amrita.pati@gmail.com> wrote:

> http://blog.codevader.com/(en) <http://blog.codevader.com/%28en%29>
> > > upon which I get the following dump:
> > > `require'
> > >        from /home/me/mygems/gems/mongrel-1.1.5/bin/mongrel_rails:11
> > >        from /home/me/mygems/bin/mongrel_rails:19:in `load'
> > >        from /home/me/mygems/bin/mongrel_rails:19
> >
> > > Does anyone have an idea as to what is going wrong here?
> >
> > > Thanks!
> >
>


--
- NAYAK
This topic is locked and can not be replied to.