Forum: Ruby on Rails RedCloth gem/pluging not working in production mode

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
F8451aa0650d328c31023a2d46117cfb?d=identicon&s=25 Paul Jonathan Thompson (Guest)
on 2009-01-14 21:03
(Received via mailing list)

I installed RedCloth 4.1.1 using - gem install RedCloth - This has
worked fine on my development (webbrick) machine.

I then did the same on my production machine which is using Apache and
Passenger. However the plugin/gem appears not to be found. Do gems and
plugins need to be handled differently in production mode or with
Apache and Passenger? This is the first time that I am using a plugin.

Assistance would be most appreciated.

Paul Thompson
59dc433a45056794ddc39e3623e91c46?d=identicon&s=25 (Guest)
on 2009-01-14 22:46
(Received via mailing list)
I had a similar problem a while back and had to add the following to
my environment.rb file:

config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://"

This should go in the block.


On Jan 14, 3:02 pm, "Paul Jonathan Thompson" <>
F8451aa0650d328c31023a2d46117cfb?d=identicon&s=25 Paul Jonathan Thompson (Guest)
on 2009-01-14 23:29
(Received via mailing list)
Hi Sheldon,

Tried what you advised. Am getting this message on starting Webrick (I
thought I would test it here before trying in production)

=> Booting WEBrick...
/usr/local/lib/site_ruby/1.8/rubygems/requirement.rb:150:in `parse':
Illformed requirement [{:source=>"",
:version=>">= 4.1.1"}] (ArgumentError)
  from /usr/local/lib/site_ruby/1.8/rubygems/requirement.rb:75:in


Paul Thompson

2009/1/15 <>:
59dc433a45056794ddc39e3623e91c46?d=identicon&s=25 (Guest)
on 2009-01-15 01:01
(Received via mailing list)
Always good to test it in development before moving it to
production. :) Never seen that error myself. Let me copy and past what
I have from the environment.rb file. I was typing that earlier post
from memory:

config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://"

This is on an app which is running rails 2.1, although it should work
fine on 2.2+. It's added just before the closing end on the block in config/environment.rb.

Sheldon F.

On Jan 14, 5:28 pm, "Paul Jonathan Thompson" <>
A66b560a1dc1f0386002e465629ce6ba?d=identicon&s=25 Nate Bird (Guest)
on 2009-01-17 00:38
(Received via mailing list)
I'm having a similar problem. My Apache log shows the following error.
Passenger doesn't load completely so the rails log isn't written to.

RedCloth 4.1.1 is also installed on the both the production and
development environments and shows up in the 'gem list' call.

I don't have problems in development (OS X, Apache, passenger) but
production is messed. I'm on Ubuntu running Apache and Passenger. I
have Rails 2.2 on both development and production environments.

#Passenger error on restart
Ruby on Rails application could not be started
The application has exited during startup (i.e. during the evaluation
of config/environment.rb). The error message may have been written to
the web server's log file. Please check the web server's log file
(i.e. not the (Rails) application's log file) to find out why the
application exited.

# Apache error log
You're running:
  ruby at /opt/ruby-enterprise-1.8.6-20081215/bin/ruby
  rubygems 1.3.1 at /home/etandrib/.gem/ruby/1.8, /opt/ruby-

Run `rake gems:install` to install the missing gems.

# environment.rb do |config|
  config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://"
This topic is locked and can not be replied to.