Forum: Ruby on Rails SMTP settings for action mailer

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0bdaf2a5cf0a401d2ee4377b9ce47581?d=identicon&s=25 Tyl Tan (tyanlion)
on 2009-01-08 09:16
(Received via mailing list)
with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => "smtp.mydomain.com",
:port => 25,
:domain => "mydomain.com",
:authentication => :plain,
:user_name => "mydomain_mailer@mydomain.com",
:password => "password"
}

both the email server and the rails app are on the same machine
if i don't have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.
9cf6e7f81d4339295b86e5fb7d7df49b?d=identicon&s=25 Vishwanath Nayak (nayak)
on 2009-01-08 09:25
(Received via mailing list)
Hi,

In your server's host file map the address smtp.mydomain.com to IP
127.0.0.1
so that it is not routed externally.

-NAYAK
0bdaf2a5cf0a401d2ee4377b9ce47581?d=identicon&s=25 Tyl Tan (tyanlion)
on 2009-01-08 10:18
(Received via mailing list)
I tried changing it to this :

127.0.0.1       localhost.localdomain   localhost smtp.mydomain.com smtp

::1 localhost6.localdomain6     localhost6

210.193.49.222 ns1.mydomain.com ns1 localhost smtp.mydomain.com smtp



But it didn’t work

Restarted postfix and mongrel gave ssl error again.



From: rubyonrails-talk@googlegroups.com
[mailto:rubyonrails-talk@googlegroups.com] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 4:24 PM
To: rubyonrails-talk@googlegroups.com
Subject: [Rails] Re: SMTP settings for action mailer



Hi,

In your server's host file map the address smtp.mydomain.com to IP
127.0.0.1 so that it is not routed externally.

-NAYAK

On Thu, Jan 8, 2009 at 1:45 PM, tyliong <tyliong@gmail.com> wrote:


with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => "smtp.mydomain.com",
:port => 25,
:domain => "mydomain.com",
:authentication => :plain,
:user_name => "mydomain_mailer@mydomain.com",
:password => "password"
}

both the email server and the rails app are on the same machine
if i don't have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.
9cf6e7f81d4339295b86e5fb7d7df49b?d=identicon&s=25 Vishwanath Nayak (nayak)
on 2009-01-08 10:34
(Received via mailing list)
Hi,

I am not sure of using multiple host/domain at a time there
Try just

127.0.0.1 smtp.mydomain.com

NAYAK
0bdaf2a5cf0a401d2ee4377b9ce47581?d=identicon&s=25 Tyl Tan (tyanlion)
on 2009-01-08 10:45
(Received via mailing list)
I got it to work with the multiple domain names



ActionMailer::Base.smtp_settings = {
:address => "smtp.mydomain.com",
:port => 25,
:domain => "mydomain.com",
:authentication => :plain,
:user_name => "mydomain_mailer@mydomain.com",
:password => "password"
}





I have the address as smtp.mydomain.com and it gives 127.0.0.1 in my
mail error log.  Instead of ns1.mydomain.com .



Is it working internally now?



From: rubyonrails-talk@googlegroups.com
[mailto:rubyonrails-talk@googlegroups.com] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 5:34 PM
To: rubyonrails-talk@googlegroups.com
Subject: [Rails] Re: SMTP settings for action mailer



Hi,

I am not sure of using multiple host/domain at a time there
Try just

127.0.0.1 smtp.mydomain.com

NAYAK

On Thu, Jan 8, 2009 at 2:57 PM, Tan YL <tyliong@gmail.com> wrote:

I tried changing it to this :

127.0.0.1       localhost.localdomain   localhost smtp.mydomain.com smtp

::1 localhost6.localdomain6     localhost6

210.193.49.222 ns1.mydomain.com ns1 localhost smtp.mydomain.com smtp



But it didn't work

Restarted postfix and mongrel gave ssl error again.



From: rubyonrails-talk@googlegroups.com
[mailto:rubyonrails-talk@googlegroups.com] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 4:24 PM
To: rubyonrails-talk@googlegroups.com
Subject: [Rails] Re: SMTP settings for action mailer



Hi,

In your server's host file map the address smtp.mydomain.com to IP
127.0.0.1 so that it is not routed externally.

-NAYAK

On Thu, Jan 8, 2009 at 1:45 PM, tyliong <tyliong@gmail.com> wrote:


with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => "smtp.mydomain.com",
:port => 25,
:domain => "mydomain.com",
:authentication => :plain,
:user_name => "mydomain_mailer@mydomain.com",
:password => "password"
}

both the email server and the rails app are on the same machine
if i don't have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.
This topic is locked and can not be replied to.