Forum: JRuby keep getting "Missing these required gems" error but gems are installed

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
74a56286718bc003d6c7438f7efa1e3a?d=identicon&s=25 Navjeet Chabbewal (jeet)
on 2009-01-07 20:37
(Received via mailing list)
I just switched from jruby 1.1.3 to jruby 1.1.6 and I keep getting the

error "Missing these required gems:" even after I have run the the
command "jruby -S rake gems:install" and the all the needed config.gem
entries in environment.rb. Also the gems listed as missing are installed
again when I run the rake target. When I run "jruby S gem list"
command, all the reported gems are listed out.

Do I need do some cleanup to fix this
problem? This is on windows XP.

Thanks.



Navjeet
http://chabbewal.blogspot.com
D28d6de06f3492ecd56fa6c45aac5dc0?d=identicon&s=25 My Name (vsg)
on 2009-01-28 21:11
Navjeet Chabbewal wrote:
> I just switched from jruby 1.1.3 to jruby 1.1.6 and I keep getting the
>
> error "Missing these required gems:" even after I have run the the
> command "jruby -S rake gems:install" and the all the needed config.gem
> entries in environment.rb. Also the gems listed as missing are installed
> again when I run the rake target. When I run "jruby S gem list"
> command, all the reported gems are listed out.
>
> Do I need do some cleanup to fix this
> problem? This is on windows XP.
>
> Thanks.
>
>
>
> Navjeet
> http://chabbewal.blogspot.com

are you using warble? if so, maybe run "jruby -S warble config". this
will create a warble.rb and inside that add the necessary config.gems in
it. and make sure to "jruby -S warble war:clean" before war-ing it again
This topic is locked and can not be replied to.