Forum: Ruby on Rails Missing Template with edge Rails (2.3)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D06df1be2a457bbe0bff40dcfff6a3e5?d=identicon&s=25 Rich (Guest)
on 2009-01-04 05:18
(Received via mailing list)
After freezing edge rails, all my controller examples are failing with
MissingTemplate errors.
e.g., "Missing template attachments/create.erb in view path app/views"

Trying to actually render the views gives me the same error.

I noticed I can fix most of them by using respond_do but I usually
never use it. I almost always only need to respond to one format in
one action so I omit respond_to and let Rails figure out which file to
render.

Will Rails no longer do this in 2.3?
D06df1be2a457bbe0bff40dcfff6a3e5?d=identicon&s=25 Rich (Guest)
on 2009-01-06 00:24
(Received via mailing list)
Correction: I meant 'respond_to', not 'respond_do'.
9a2a53db8e9b4476038c94a64b32833f?d=identicon&s=25 Ryan Bigg (ryan-bigg)
on 2009-01-06 00:28
(Received via mailing list)
It's trying to render a create view and generally create actions don't
have a view, they just redirect somewhere (probably to the object that
was just created). Make sure in your controller that it's definitely
redirecting or doing *something* other than trying to render that view.
-----
Ryan Bigg
Freelancer
http://frozenplague.net
D06df1be2a457bbe0bff40dcfff6a3e5?d=identicon&s=25 Rich (Guest)
on 2009-01-06 00:31
(Received via mailing list)
It's not just create, it's seemingly all my actions. I just found this
though:

http://rails.lighthouseapp.com/projects/8994/ticke...
This topic is locked and can not be replied to.