Forum: Ruby on Rails Specifying Active Support Version in environment.rb

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
499d5675674d552642cd636a0122b849?d=identicon&s=25 John (Guest)
on 2009-01-02 18:12
(Received via mailing list)
Hello.

I am getting this error...

C:/dev/ccx_aucxtion_ccx/config/boot.rb:20:Warning:
Gem::SourceIndex#search support for String patterns is deprecated
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate activesupport (= 1.4.4, runtime), already activated active
support-2.2.2 (Gem::Exception)

Is there a way to specify the Active Support version in
environment.rb?  I see there is a way to specify the Rails version...

RAILS_GEM_VERSION = '1.2.6' unless defined? RAILS_GEM_VERSION

Please let me know.
Thanks,
John
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2009-01-02 18:14
(Received via mailing list)
On 2 Jan 2009, at 16:50, John wrote:

> support-2.2.2 (Gem::Exception)
>
> Is there a way to specify the Active Support version in
> environment.rb?  I see there is a way to specify the Rails version...
>
A particular version of rails is tied to a particular version of
activesupport. The error message you've got means that something
required a newer version of activesupport before rails loaded its
version.

Fred
This topic is locked and can not be replied to.