Forum: Ruby on Rails gem_original_require no such file to load -- /var/www/vhosts/gophotoswap.com/httpdocs/current/config

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
91c6e26e978931239dbb18ae3e98d863?d=identicon&s=25 Matt McF (Guest)
on 2009-01-01 21:01
(Received via mailing list)
** Daemonized, any open files are closed.  Look at /var/www/vhosts/
gophotoswap.com/httpdocs/shared/pids/mongrel.8000.pid and /var/www/
vhosts/gophotoswap.com/httpdocs/shared/log/mongrel.8000.log for info.
** Starting Mongrel listening at 127.0.0.1:8000
** Initiating groups for "mongrel":"mongrel".
** Changing group to "mongrel".
** Changing user to "mongrel".
** Starting Rails with production environment...
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- /var/www/vhosts/
gophotoswap.com/httpdocs/current/config/environment (LoadError)
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `require'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/rails.rb:147:in `rails'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:113:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `call'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `listener'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:99:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `call'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `initialize'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `new'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/command.rb:212:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:281
  from /usr/local/bin/mongrel_rails:19:in `load'
  from /usr/local/bin/mongrel_rails:19

******************
gem env
******************
gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.2.0
  - RUBY VERSION: 1.8.6 (2007-03-13 patchlevel 0) [i686-linux]
  - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /usr/local/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/local/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /usr/local/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/", "http://
gems.github.com"]
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
     - http://gems.github.com
 ----------------
gem -v = 1.2.0
rails -v = 2.1.2
ruby -v = ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-linux]



any clue???
91c6e26e978931239dbb18ae3e98d863?d=identicon&s=25 Matt McF (Guest)
on 2009-01-03 18:46
(Received via mailing list)
This has been solved.

Make sure all permissions on the symlink current, the dirs shared/pids
shared/log, shared/tmp are all set to 755
This topic is locked and can not be replied to.