Forum: JRuby JRoR plugin loading issue on Websphere

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bb4bdf2b184027bc38d4fb529770cde5?d=identicon&s=25 Wes Gamble (weyus)
on 2008-12-31 22:18
(Received via mailing list)
All,

Rails 2.1
JRuby 1.1.4
JDK 1.5
Websphere 6.1

I have a Rails app. that is deployed to Websphere AS 6.1 using Goldspike
1.6.1.

We are using engines, and the app. will successfully run using both
standalone MRI/mongrel and standalone JRuby/mongrel.  When I package it
up as a WAR file however, I get the following error on loading the
"engines" plugin:

[12/31/08 15:00:18:264 CST] 00000092 WebApp        A   SRVE0180I:
[Servlet.LOG]: Failed to load Rails: Could not locate the following
plugins: engines

I am certain that the engines plugin is present in the deployed
application.

I'm thinking that maybe I need to do something special with
config.plugin_paths in the Rails initializer block because I am
deploying into a JEE server.

Anyone else ever run into engines loading problems with Rails in a JEE
environment?

Thanks,
Wes

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
This topic is locked and can not be replied to.