Forum: Ruby on Rails ror plugins - in_place_editing and acts_as-textiled - install error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1acb27fb6f6e7322ef834fb2ab299b16?d=identicon&s=25 suman gurung (Guest)
on 2008-12-22 14:31
(Received via mailing list)
Hello everyone,

I was trying to install these in_place_editing and acts_as_textiled
plugins in my rails application version 2.2.2, running on windows XP
but i came across some problems when doing so.

When i was trying to install in_place_editing, using the command
ruby script/plugin install
http://svn.rubyonrails.org/rails/plugins/in_place_editing

i got the error
plugin not found: ["in_place_editing"]

I tried to browse the svn repository,
http://svn.rubyonrails.org/rails/plugins/
using tortoisesvn, and i couldn't get any plugins listed in my
tortoisesvn.

When i tried to install acts_as_textiled plugin, from the repository
ruby script/plugin install
svn://errtheblog.com/svn/plugins/acts_as_textiled

i got the error
svn: Can't connect to the host 'errtheblog.com'


Has the plugins been moved to a different directory?? i believe these
are fairly popular plugins, so i hope i can get some help here.
thanks,
suman
C64e63b70be7dfed8b0742540b8b27e5?d=identicon&s=25 Mark Reginald James (Guest)
on 2008-12-22 19:40
(Received via mailing list)
suman gurung wrote:

> I was trying to install these in_place_editing and acts_as_textiled
> plugins in my rails application version 2.2.2, running on windows XP
> but i came across some problems when doing so.
> ...
> Has the plugins been moved to a different directory?? i believe these
> are fairly popular plugins, so i hope i can get some help here.

Both have now been moved to git.

Here are installation instructions:
   http://railswheels.com/acts-as-textiled
   http://railswheels.com/in-place-editing

--
Rails Wheels - Find Plugins, List & Sell Plugins -
http://railswheels.com
1acb27fb6f6e7322ef834fb2ab299b16?d=identicon&s=25 suman gurung (Guest)
on 2008-12-23 17:03
(Received via mailing list)
Thanks mark for the links.

I am running on windows and it is always a problem atleast for me to
install using git..
Any idea of easy way or tutorial to use install these plugins from
github easily on windows??
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2008-12-23 17:31
(Received via mailing list)
On 23 Dec 2008, at 16:02, suman gurung wrote:

>
> Thanks mark for the links.
>
> I am running on windows and it is always a problem atleast for me to
> install using git..
> Any idea of easy way or tutorial to use install these plugins from
> github easily on windows??

You can download tarballs/zip files off github.
C64e63b70be7dfed8b0742540b8b27e5?d=identicon&s=25 Mark Reginald James (Guest)
on 2008-12-23 17:51
(Received via mailing list)
Frederick Cheung wrote:

> You can download tarballs/zip files off github.

Ah, thanks Fred. I've added ZIP download links to
those plugin listings.

--
Rails Wheels - Find Plugins, List & Sell Plugins -
http://railswheels.com
Fcb68cc03b9d22c69030fb84290b3a96?d=identicon&s=25 morgler (Guest)
on 2008-12-26 17:21
(Received via mailing list)
When I try to do a "ruby script/plugin install
git://github.com/rails/in_place_editing"
on my WinXP install, I always get the message "removing: I:
\instant_rails\...\in_place_editing\.git". What do I do wrong?
1acb27fb6f6e7322ef834fb2ab299b16?d=identicon&s=25 suman gurung (Guest)
on 2008-12-26 21:48
(Received via mailing list)
You should follow the link provided by Mark Reginald  which is
 http://railswheels.com/acts-as-textiled
   http://railswheels.com/in-place-editing
1acb27fb6f6e7322ef834fb2ab299b16?d=identicon&s=25 suman gurung (Guest)
on 2008-12-26 21:51
(Received via mailing list)
Sorry about my previous post, clicked the on the 'enter' button
prematurely....

You should follow the link posted by mark reginald. And then you
should download the zip version of the plugin. After doing that you
extract the files and copy all the extracted files into the vendor/
plugins/in_place_editing folder of your rails app. You should create
the in_place_editing folder yourself.
Then you restart the server to make the changes come into effect.
This topic is locked and can not be replied to.