Forum: Ruby on Rails Missing Dependency subversion is needed by package subversion-ruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C0f85be93498013f2a5401de78f37bb1?d=identicon&s=25 imarichardson (Guest)
on 2008-12-17 20:18
(Received via mailing list)
Greets.

I'm currently trying to install GIT on an RHEL5 box. I've tried to
both build from source and install via yum. In both instances I
continue to receive the error message (full error stack at the end):

[code]Error: Missing Dependency: subversion = 1.4.2-2.el5 is needed by
package subversion-ruby[/code]

If I'm reading this correctly I'm seeing that svn version 1.4.2 is
needed however I am running version 1.4.2 on the system:

[code]
$ svn --version
svn, version 1.4.2 (r22196)
   compiled Nov 20 2006, 07:17:37

Copyright © 2000-2006 CollabNet.
Subversion is open source software, see [url="http://
subversion.tigris.org/"]http://subversion.tigris.org/[/url]
This product includes software developed by CollabNet (http://
www.Collab.Net/).

The following repository access (RA) modules are available:

* ra_dav : Module for accessing a repository via WebDAV (DeltaV)
protocol.
  - handles 'http' scheme
  - handles 'https' scheme
* ra_svn : Module for accessing a repository using the svn network
protocol.
  - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
  - handles 'file' scheme
[/code]

The system has been running for nearly four years and I've only come
across this problem when trying to install yum. Subversion is running
without any issues and I've several ruby apps that are having no
difficulty at all using the bindings.

I have been searching everywhere and cannot find any references to how
someone gets around the problem. I confess I'm no linux deity so any
help would be appreciated. Thanks so much in advance for whatever help
comes this way.

Here's the full output from a yum install (thanks again):
[code]
$ sudo yum install git
Password:
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Loading "protectbase" plugin
Setting up Install Process
Setting up repositories
ruby186                   100% |=========================|  951 B
00:00
rpmforge                  100% |=========================| 1.1 kB
00:00
rhel-i386-server-5        100% |=========================| 1.4 kB
00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 2.9 MB
00:02
################################################## 8139/8139
primary.xml.gz            100% |=========================| 1.6 MB
00:02
################################################## 4489/4489
0 packages excluded due to repository protections
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package git.i386 0:1.5.2.1-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(SVN::Ra) for package: git
--> Processing Dependency: perl(LWP::UserAgent) for package: git
--> Processing Dependency: perl(SVN::Core) for package: git
--> Processing Dependency: perl(SVN::Delta) for package: git
--> Processing Dependency: perl(Git) for package: git
--> Processing Dependency: rcs for package: git
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-libwww-perl.noarch 0:5.805-1.1.1 set to be updated
---> Package perl-Git.i386 0:1.5.2.1-1.el5.rf set to be updated
---> Package rcs.i386 0:5.7-30.1 set to be updated
---> Package subversion-perl.i386 0:1.5.4-0.1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-
libwww-perl
--> Processing Dependency: perl(Compress::Zlib) for package: perl-
libwww-perl
--> Processing Dependency: subversion = 1.5.4-0.1.el5.rf for package:
subversion-perl
--> Processing Dependency: perl(Error) for package: perl-Git
--> Processing Dependency: perl(HTML::Entities) for package: perl-
libwww-perl
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Compress-Zlib.i386 0:1.42-1.fc6 set to be updated
---> Downloading header for perl-HTML-Parser to pack into transaction
set.
perl-HTML-Parser-3.59-1.e 100% |=========================| 7.3 kB
00:00
---> Package perl-HTML-Parser.i386 0:3.59-1.el5.rf set to be updated
---> Package subversion.i386 0:1.5.4-0.1.el5.rf set to be updated
---> Package perl-Error.noarch 0:0.17015-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-
Parser
--> Processing Dependency: subversion = 1.4.2-2.el5 for package:
subversion-ruby
--> Processing Dependency: subversion = 1.4.2-2.el5 for package:
mod_dav_svn
--> Processing Dependency: subversion = 1.4.2-2.el5 for package:
subversion-devel
--> Processing Dependency: libsvn_ra_dav-1.so.0 for package:
subversion-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package subversion-devel.i386 0:1.5.4-0.1.el5.rf set to be
updated
---> Package mod_dav_svn.i386 0:1.5.4-0.1.el5.rf set to be updated
---> Package perl-HTML-Tagset.noarch 0:3.20-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: subversion = 1.4.2-2.el5 for package:
subversion-ruby
--> Finished Dependency Resolution
Error: Missing Dependency: subversion = 1.4.2-2.el5 is needed by
package subversion-ruby
[/code]
This topic is locked and can not be replied to.