Forum: NGINX Problem compiling nginx-0-6-34 on CentOS 5.2 x86_64

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
03896853460d3f4cbaff5395125719f5?d=identicon&s=25 Yazz Atlas (Guest)
on 2008-12-12 00:13
(Received via mailing list)
Attachment: failed-make.txt (40 KB)
I am unable to compile nginx with SSL support under CentOS 5.2 x86_64
currently.

./configure --prefix=/opt/nginx --with-openssl=/usr/lib64 \
                 --with-md5=/usr/lib64 --with-sha1=/usr/lib64 \
                 --with-http_ssl_module

Configuration summary
  + using system PCRE library
  + using OpenSSL library: /usr/lib64
  + using md5 library: /usr/lib64
  + using sha1 library: /usr/lib64
  + using system zlib library

  nginx path prefix: "/opt/nginx"
  nginx binary file: "/opt/nginx/sbin/nginx"
  nginx configuration prefix: "/opt/nginx/conf"
  nginx configuration file: "/opt/nginx/conf/nginx.conf"
  nginx pid file: "/opt/nginx/logs/nginx.pid"
  nginx error log file: "/opt/nginx/logs/error.log"
  nginx http access log file: "/opt/nginx/logs/access.log"
  nginx http client request body temporary files:
"/opt/nginx/client_body_temp"
  nginx http proxy temporary files: "/opt/nginx/proxy_temp"
  nginx http fastcgi temporary files: "/opt/nginx/fastcgi_temp"

During the make process it fails. I attached the output since its way
to long to paste.
A8108a0961c6087c43cda32c8616dcba?d=identicon&s=25 Maxim Dounin (Guest)
on 2008-12-12 01:53
(Received via mailing list)
Hello!

On Thu, Dec 11, 2008 at 03:01:26PM -0800, Yazz Atlas wrote:

> I am unable to compile nginx with SSL support under CentOS 5.2 x86_64
> currently.
>
> ./configure --prefix=/opt/nginx --with-openssl=/usr/lib64 \
>                  --with-md5=/usr/lib64 --with-sha1=/usr/lib64 \
>                  --with-http_ssl_module

Configure options '--with-openssl', '--with-md5' and '--with-sha1'
define paths to appropriate library *sources* and should be
used only if you want to compile them with nginx itself.  For
obvious reasons your configure string is wrong.

Use --with-cc-opt and --with-ld-opt instead as appropriate.  Something
like this will probably do the trick:

./configure --prefix=/opt/nginx \
    --with-ld-opt="-L /usr/lib64" \
    --with-http_ssl_module

Maxim Dounin
F5a6ed477b109fe6acc11a5a8f87e7e8?d=identicon&s=25 mike (Guest)
on 2008-12-12 02:37
(Received via mailing list)
I believe I had issues on RHEL 5.x myself, and I solved it by removing
the 32-bit libraries (most things I were compiling were confused
between the 64-bit and 32-bit and it wound up mixing the two,
resulting in compilation errors)

I wish they would work like Ubuntu which has made it pure 64-bit
without default installing 32-bit libs as well.
B9340b8cfd6b4038536e58327ef648c9?d=identicon&s=25 Arvind Jayaprakash (Guest)
on 2008-12-12 21:13
(Received via mailing list)
mike wrote:
> I believe I had issues on RHEL 5.x myself, and I solved it by removing
> the 32-bit libraries (most things I were compiling were confused
> between the 64-bit and 32-bit and it wound up mixing the two,
> resulting in compilation errors)
>
> I wish they would work like Ubuntu which has made it pure 64-bit
> without default installing 32-bit libs as well.

Does passing the "-m64" to gcc help (--with-cc-opt)? It clearly tells
gcc that you intend to make a64 bit elf object. That might be cleaner
than explicitly choosing all the lib64 paths.
F5a6ed477b109fe6acc11a5a8f87e7e8?d=identicon&s=25 mike (Guest)
on 2008-12-12 21:35
(Received via mailing list)
I never tried. It might have. I didn't really have the patience to try
to figure out this stuff, I didn't want to mess with this for each
daemon giving me hassle so I just removed the confusion :)

On Fri, Dec 12, 2008 at 12:04 PM, Arvind Jayaprakash
Ae36591847393e58ff189704f5eb18f2?d=identicon&s=25 Jeremy Hinegardner (Guest)
on 2008-12-18 01:26
(Received via mailing list)
On Thu, Dec 11, 2008 at 03:01:26PM -0800, Yazz Atlas wrote:
> I am unable to compile nginx with SSL support under CentOS 5.2 x86_64
> currently.
>
> ./configure --prefix=/opt/nginx --with-openssl=/usr/lib64 \
>                  --with-md5=/usr/lib64 --with-sha1=/usr/lib64 \
>                  --with-http_ssl_module

nginx is available for Centos in the EPEL repository.  It is currently
at 0.6.33
and will be update to 0.6.34 soon.  You may need to enable the testing
repo.

  http://fedoraproject.org/wiki/EPEL/FAQ#howtouse

And then 'yum install nginx'

enjoy,

-jeremy
This topic is locked and can not be replied to.