Forum: GNU Radio USRP2 daughterboard recognition error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3423ab73376d97983709f0437aee9925?d=identicon&s=25 ILKYOUNG KWOUN (Guest)
on 2008-12-10 13:15
(Received via mailing list)
Hello, folks,

It seems that my USRP2 won't recognize the presence of daughtercard
correctly.

What I did today was running the 'usrp2_wfm_rcv.py' program in sample
directory and I could not managed the program running correctly. While
I was tracking down the problem, I unplugged my basicRX daughterboard
from the USRP2 and ran 'usrp2_rx_cfile.py in 'gr-utils/src/python'
directory. The followings are the result.

------------------------------------------------------------------
Using mid-point gain of 0.0 ( 0.0 - 0.0 )
Network interface: eth0
USRP2 address: 00:50:c2:85:30:3f
Using RX d'board id 0x0001
Rx gain: 0.0
Rx baseband frequency: 0
Rx DDC frequency: 4.9M
Rx residual frequency: 11.735m
Rx decimation rate: 16
Rx sample rate: 6.25M
Receiving samples until Ctrl-C
Writing 32-bit complex floats
Output filename: RxDump
------------------------------------------------------------------

As you can see, the program detects the RX daughterboard id as  0x0001
while no daughterboard is connected to the mainboard.
That is just the same result out of a test with the daughterboard
connected on the right place. So, I'm very suspicious if the program
does not investigate the presence of daughtercard correctly.

I can do further test with DBRX(?) daughterboard at home but it would
take some time because I have to replace the main board of my
computer. So, I just wonder if I can get a help out there having a
clue on my case.

Best regards,

Ilkyoung.
3423ab73376d97983709f0437aee9925?d=identicon&s=25 ILKYOUNG KWOUN (Guest)
on 2008-12-10 15:50
(Received via mailing list)
FYI,
  - My host is ubuntu 8.10 AMD64 on an Intel Core2Duo
  - The FPGA image file is u2_rev3.bin
(http://gnuradio.org/releases/usrp2-bin/trunk/)
  - The FPGA firmware file is txrx.bin dated 03-Nov-2008
(http://gnuradio.org/releases/usrp2-bin/trunk/)

2008/12/10 ILKYOUNG KWOUN <hl1oap@gmail.com>:
D0072e69d706bb3ca211d33a1b536e2c?d=identicon&s=25 Johnathan Corgan (Guest)
on 2008-12-10 19:10
(Received via mailing list)
On Wed, Dec 10, 2008 at 4:15 AM, ILKYOUNG KWOUN <hl1oap@gmail.com>
wrote:

> It seems that my USRP2 won't recognize the presence of daughtercard correctly.
[...]
> As you can see, the program detects the RX daughterboard id as  0x0001
> while no daughterboard is connected to the mainboard.
> That is just the same result out of a test with the daughterboard
> connected on the right place. So, I'm very suspicious if the program
> does not investigate the presence of daughtercard correctly.

The code is designed to identify as a BasicRX if it doesn't identify
any other card.  This is primarily for debugging purposes.

But there does seem to be an issue that we are sending back a 0 - 0
gain range in this case, and not handling it correctly elsewhere.

> I can do further test with DBRX(?) daughterboard at home but it would
> take some time because I have to replace the main board of my
> computer. So, I just wonder if I can get a help out there having a
> clue on my case.

The DBSRX board is not yet supported by the USRP2 software.

What was the daughterboard you were originally trying to use?

-Johnathan
This topic is locked and can not be replied to.