Forum: wxRuby wxruby2-0-1 not working on windows 2008

3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 15:03
(Received via mailing list)
Hi everyone,

I've installed wxruby-2.0.1-x86-mswin32-60 on windows 2008 via gem
install.

When I try to use it I get a "Specified module could not be found:
wxruby2.so"
Needless to say I have the file where it's suppose to be.

Any idea what's wrong?
wxruby supports windows 2008?

Thanks,
Idan.
06f6780c99d4a8dd71f2b474082ea9ce?d=identicon&s=25 Alex Fenton (Guest)
on 2011-05-17 15:05
(Received via mailing list)
On 17/05/2011 14:01, Idan Miller wrote:

> I've installed wxruby-2.0.1-x86-mswin32-60 on windows 2008 via gem install.
>
> When I try to use it I get a "Specified module could not be found:
> wxruby2.so"
> Needless to say I have the file where it's suppose to be.
>
> Any idea what's wrong?
> wxruby supports windows 2008?

I don't know, since I don't have Windows 2008. One thing to check is
which version of ruby you're using (the latest installers are mingw, I
think). What does ruby -v say?

alex
3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 15:20
(Received via mailing list)
1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
06f6780c99d4a8dd71f2b474082ea9ce?d=identicon&s=25 Alex Fenton (Guest)
on 2011-05-17 15:25
(Received via mailing list)
On 17/05/2011 14:07, Idan Miller wrote:
> 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

In that case, I'm not sure. Do other user-installed libraries with
compiled extensions work correctly with that Ruby on Win2008? Could you
try a newer mingw Ruby?
3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 15:34
(Received via mailing list)
Not sure about other extensions...
You mean try the mingw gem?
06f6780c99d4a8dd71f2b474082ea9ce?d=identicon&s=25 Alex Fenton (Guest)
on 2011-05-17 15:55
(Received via mailing list)
On 17/05/2011 14:27, Idan Miller wrote:
> Not sure about other extensions...
> You mean try the mingw gem?

I mean try one of the latest Ruby for Windows installers from here:
http://rubyinstaller.org/

These are built from more recent Ruby codebases, and use the MingW
rather than Microsoft (mswin32) compiler.

It says that it supports Windows 7
https://github.com/oneclick/rubyinstaller/wiki/faq#win_ver

I think it's unlikely that we can continue to support wxRuby on Ruby
built with the MS compiler any longer - I don't have the build
environment any longer, and I don't think anyone else ever did.

alex
3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 16:02
(Received via mailing list)
My biggest problem is that I'm using watir, which requires ruby 1.8.6
and is
not yet stable on ruby 1.9.
So I have to use 1.8.6... and that causes wxRuby not to work on windows
2008...

Any other idea?

Thanks,
Idan.
3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 16:03
(Received via mailing list)
btw, on windows 7 it works, still makes sense?

Idan.
85991f138ede6236f35eb98da22b7b01?d=identicon&s=25 Marvin Gülker (quintus)
on 2011-05-17 17:55
(Received via mailing list)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 17.05.2011 15:57, schrieb Idan Miller:
> My biggest problem is that I'm using watir, which requires ruby 1.8.6 and is
> not yet stable on ruby 1.9.
> So I have to use 1.8.6... and that causes wxRuby not to work on windows
> 2008...
>
> Any other idea?
>
> Thanks,
> Idan.

If Watir doesn't support Ruby 1.9 (a shame!), then why don't you use
1.8.7, which is the latest Ruby from the 1.8 branch?

Vale,
Marvin

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJN0plfAAoJELh1XLHFkqhaR2QIAII4J6hVRbbNhHKMQtW+3qtc
5rHIjVS2k90F0HF2YhqRDUep9RewQuULNCYj1cyawnXKM/afpmiwLpfK0ZX996Vu
ae5mOIQ2GkyDqhvu846IuOPn2EX/YmT6rv51WdviRgkBhCkr9lZJ4o7OHzgJRfpI
Se4iqBiz9sDmRVuY4Ai7Fc1bR2nB14j1WIeV5JKgf0azoWwUSDOWrXy8vabqvjIt
Ozh88G0GGyjfTkmPIK24N3lbeRWp4P/QVf8M/9wSOxJdEEy+kcOcBS7ycF4ubEs3
QBrY0XRgIANRj83PpuMP8gKwSY3CXfjJ8a8VzkdazIFauC4q9EBWB1Xb8eyFkPM=
=DsMO
-----END PGP SIGNATURE-----
3cc34877c3c8e726cbe5c2dcda495870?d=identicon&s=25 Idan Miller (idanmiller)
on 2011-05-17 18:20
(Received via mailing list)
Will 1.8.7 do better? 1.8.7 is supported.

Idan.
06f6780c99d4a8dd71f2b474082ea9ce?d=identicon&s=25 Alex Fenton (Guest)
on 2011-05-17 18:32
(Received via mailing list)
On 17/05/11 17:02, Idan Miller wrote:
> Will 1.8.7 do better? 1.8.7 is supported.
>
>
>     If Watir doesn't support Ruby 1.9 (a shame!), then why don't you use
>     1.8.7, which is the latest Ruby from the 1.8 branch?
>

I can't say whether it will work with Windows 2008, but I would
certainly try the rubyinstaller built with mingw, as per earlier link,
and then try the mingw 1.8.7 gem for wxRuby:
http://rubyforge.org/frs/download.php/63472/wxruby...

(Please don't top-post).

alex
This topic is locked and can not be replied to.