Forum: Ruby on Rails Rails and Ruby behind proxy

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3209b5c52f62e56092f26d87492f097f?d=identicon&s=25 Nicolas Alpi aka Spyou (Guest)
on 2008-12-09 10:29
(Received via mailing list)
Hi there,

I've a little problem.

On my code, I use the flickraw gem. On the application.rb there is a
require 'flickraw' who create a new instance, and for that need to
pass the net.

It works at home, but in my office we have a proxy, and when I launch
webrick  I have an error saying that I'm behind a proxy :(.

Does anyone have an idea on how to correct this issue ? Is there a
config.http_proxy in environement.rb or something like that ?

Thank you very much

Nic
3209b5c52f62e56092f26d87492f097f?d=identicon&s=25 Nicolas Alpi aka Spyou (Guest)
on 2008-12-09 11:36
(Received via mailing list)
Reply to myself,

I've temporary corrected this by adding Net::HTTP::Proxy
("xxxx","8080") in the code of the gem.

I'll try to submit a patch with an ENV.

Cheers

Nic

On Dec 9, 9:29 am, Nicolas Alpi aka Spyou <nicolas.a...@gmail.com>
D6434aa0b7b350f8c3ed0119d81b2ead?d=identicon&s=25 Roy Pardee (rpardee)
on 2008-12-09 17:12
(Received via mailing list)
Try setting an environment variable like so:

  http_proxy=http://my.proxy.server.mycompany.com:port_number

With the appropriate URI to your proxy server of course.

HTH,

-Roy
This topic is locked and can not be replied to.